All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 
i but a new battery in my 1999 ford taurus n now the raido dont work at all


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 319
Images: 4
First thing to do is check the fuses. If you jump started it, or caused a spark when replacing the battery, you may have blown a fuse. You could have also damaged the radio if it does not work at all.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Replacing the Catalytic converter(s) on a 1996 Windstar 3.8L

in Ford Cars

segehrand

1

838

Sat Apr 01, 2017 8:07 pm

carriedi View the latest

New Articles View the first 2001 Expedition; dying and will - NEW alternator and battery

in Ford Trucks

glminor

1

2180

Mon Jan 04, 2016 3:30 am

carriedi View the latest

New Articles View the first Ford F-250 Accessories

in Ford Trucks

edwinfoxx1475

1

349

Sat Dec 23, 2017 2:28 pm

carriedi View the latest

New Articles View the first Ford Truck Accessories

in Ford Cars

rusgrant83

1

332

Tue Jan 23, 2018 5:59 am

carriedi View the latest

New Articles View the first Ford 302 exhaust problem

in Ford Trucks

Topher

1

1482

Sat Apr 09, 2016 12:21 pm

carriedi View the latest

New Articles View the first Ford ranger fuse blowing

in Ford Trucks

bbuddy

2

2295

Thu Oct 27, 2016 7:39 pm

Davefitz View the latest

New Articles View the first 95 ford fuel system 5.8 f350

in Ford Trucks

rick123458

1

1037

Sun Jan 22, 2017 3:06 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us