93 Buick century special transmission problem

Buick Regal, Century and Park Avenue as well as the Rendezvous and Lesabre.
Ask our auto mechanics for help to all your Buick questions now.
Post Reply New Topic
sawred
Posts: 2
Joined: Sat Feb 01, 2014 6:06 pm

93 Buick century special transmission problem

Unread post by sawred » Sun Feb 02, 2014 2:34 am

I have a 93 Buick century special 3.3 v6. It has new catalytic convertor,new throttle positioning sensor, new oxygen sensor, new pcv valve. It runs great the gears on dash are 1,2,D no circle around it just causal D when i try to accelerate best way to describe it is feels like its choking itself out. I have to feather the gas to get it going. Before i know it im 35mph before it shifts from 1rst to 2nd after it hits drive its fine if i have to slow down enough to down shift to 1rst it does it all over again i cleaned maf too i asked couple mechanic about my car one said sounds like a bad ecm i checked auto parts store for price they said my cars transmission doesn't run off the ecm a 4 speed does a 3 speed doesn't. The other mechanic said could be shift solenoid or pressure modulator both $30 parts how long does is take to replace a shift solenoid? Or pressure modulator? So i can figure what I'll pay labor for my mechanic to change them he

 

User avatar
carriedi
Posts: 2267
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 93 Buick century special transmission problem

Unread post by carriedi » Wed Feb 05, 2014 1:44 am

you should have a mechanic look at your car to see why your engine seems to struggle when accelerating. Drive with a scanner on it and see what the data stream shows. if your transmission has a vacuum modulator for shifting, engine running badly will screw up the vacuum.

sawred
Posts: 2
Joined: Sat Feb 01, 2014 6:06 pm

Re: 93 Buick century special transmission problem

Unread post by sawred » Thu Feb 13, 2014 6:57 pm

I took it to a couple different mechanics told it could be a number of things from a bad ecm ,shifting solenoid, or vacuum modulator. If its something i dont need any special tool for like pulling the modulator outta the back of the trans i could probably do that myself i just don't know if theirs any special way or clips that need to come off the old one and be put on the new one i was told if i pull the hose off and fluid comes out the modulator is.bad replace it now i just have to locate it to check it online it says its behind the trans looks like a can going into tranny with a hose on the end the 1mechanic said on my car its under thehood????? I was told by 2 different auto parts stores my cars trans doesnt run off the ecm so i can rule that out hopefully lol

User avatar
carriedi
Posts: 2267
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 93 Buick century special transmission problem

Unread post by carriedi » Fri Feb 14, 2014 9:08 am

if your vehicle has a vacuum modulator here is a picture of where it would be. It is held in with one bracket. Unbolt and remove the the bracket, then slowly walk out the modulator.
Attachments
modulator.jpg
modulator.jpg (122.31 KiB) Viewed 3902 times

Post Reply