Engine dies after warming up

Ask our auto mechanics for help to all your Saturn questions.
Post Reply New Topic
fc4189
Posts: 1
Joined: Thu Oct 01, 2015 3:50 pm

Engine dies after warming up

Unread post by fc4189 » Thu Oct 01, 2015 4:02 pm

I have a 2004 Ion Redline. Nearly every morning as soon as the engine reaches normal operating temperature, when I push in the clutch to stop at an intersection, the engine dies. The revs immediately go to 0 (it does not try to idle). After doing this, I can re-start the car with no problem and it will not happen again until the next day - even if the engine cools down completely the same day. It seems to be connected to the amount of gas in the tank. This normally happens when the tank is half full or lower. It also does the same thing when I fill up the gas tank. When I start the car after filling it up, the engine refuses to idle for 15 - 25 seconds. I have replaced the EVAP solenoid in the engine compartment. I am getting two engine codes. I don't remember the "P" codes. One of them is "Bank 1 running lean" he other refers to the EVAP system, but I can't remember what it is.

 

User avatar
carriedi
Posts: 2268
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: Engine dies after warming up

Unread post by carriedi » Fri Oct 02, 2015 2:17 am

I would check into the evap code. If you have the wrong solenoid open or closed it will draw gas from you fuel tank. That's why filling gas affects it. It floods the engine. Next time you fill up and it doesn't start right away push the throttle all the way to the floor. That tells the computer to shut off the fuel while cranking (clear flood) If it starts up that way then it most likely is the evap problem.
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post