1997 sl2 1.9 saturn

Ask our auto mechanics for help to all your Saturn questions.
AaronMG21
Posts: 8
Joined: Thu Sep 11, 2014 8:31 pm

1997 sl2 1.9 saturn

Unread post by AaronMG21 » Thu Sep 11, 2014 9:00 pm

Recently i changed my motor, Completed the process. Unfortunately, when i start the vehicle and turn into gear "Reverse" "Drive" "2" "1" it stalls instantaneously. Just replaced motor and transmission fluid/filters brand new, New TPS sensore, Shifter automatic cable used but replaced. Also on the top right of my starter which is located right where the trans/engine meet i have some connector that massively sprays motor oil "Seal missing i'm guessing. Need some guidance and thoughts of what could be the reason for this issue thanks, I did get it to go in reverse for a moment actually backing it up into my driveway but then shut off. "Good battery connection to everything" Ruled out.. Thanks

 

User avatar
carriedi
Posts: 2266
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 1997 sl2 1.9 saturn

Unread post by carriedi » Thu Sep 11, 2014 9:56 pm

so if you start the engine and do not put it in gear it will run fine and you can rev the engine up and everything as long as you don't put it in gear?
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

AaronMG21
Posts: 8
Joined: Thu Sep 11, 2014 8:31 pm

Re: 1997 sl2 1.9 saturn

Unread post by AaronMG21 » Fri Sep 12, 2014 6:57 am

Correct, Started working in gear now as long as i do not slow down or come to a complete stop and when i change from park to reverse or drive i have to do it fast and give some gas for it to work.

User avatar
carriedi
Posts: 2266
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 1997 sl2 1.9 saturn

Unread post by carriedi » Fri Sep 12, 2014 10:31 am

you should check your torque converter lock up.
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

AaronMG21
Posts: 8
Joined: Thu Sep 11, 2014 8:31 pm

Re: 1997 sl2 1.9 saturn

Unread post by AaronMG21 » Fri Sep 12, 2014 12:26 pm

therefor i should remove the transmission and fill the torque manually with t-fluid?

User avatar
carriedi
Posts: 2266
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 1997 sl2 1.9 saturn

Unread post by carriedi » Fri Sep 12, 2014 2:24 pm

no! the torque converter lock up is a switch for the converter. you should check with a tranny shop to have it checked.
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

AaronMG21
Posts: 8
Joined: Thu Sep 11, 2014 8:31 pm

Re: 1997 sl2 1.9 saturn

Unread post by AaronMG21 » Fri Sep 12, 2014 3:20 pm

Ahh i see, Thx for the info ill take a look into that. also the oil leakage i have that's coming through the connector i believe is the automatic oil pressure switch, Anything i should worry about or just get the seal for it? or can i pack some panel bond around the leakage?

User avatar
carriedi
Posts: 2266
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 1997 sl2 1.9 saturn

Unread post by carriedi » Fri Sep 12, 2014 11:34 pm

if your oil pressure switch is leaking just get a new one. they just screw in and plug the harness connector to it. if that is what's is leaking.
Attachments
saturn op switch.jpg
saturn op switch.jpg (74.59 KiB) Viewed 2471 times
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

AaronMG21
Posts: 8
Joined: Thu Sep 11, 2014 8:31 pm

Re: 1997 sl2 1.9 saturn

Unread post by AaronMG21 » Sat Sep 13, 2014 12:43 pm

Thats the one, Thanks. Will it have anything to do with what its doing to the stall?

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post