rr brake & turn signal dont work

axeman
Posts: 1
Joined: Tue Aug 18, 2015 7:38 am

rr brake & turn signal dont work

Unread post by axeman » Fri Sep 18, 2015 10:16 am

having a problem with rr turn signal & brake lite 2011 Chevy express van. checked bulb its ok went to check fuses & found no provisions for fuses in under hood fuse block. checked fuse block under seat &found no brake or turn signal fuses whats up with that & where do I go from here?

User avatar
carriedi
Posts: 2295
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: rr brake & turn signal dont work

Unread post by carriedi » Fri Sep 18, 2015 6:29 pm

You need to do some electrical testing. Your brake lights and tail lights are powered by the body control module. there is a park light relay and fuses for the park lights under the drivers seat. Check the Rt rear park lamp fuse. There are 4 fuses for the BCM in the under hood fuse box.

the right rear turn and brake comes from the BCM. they go to the drivers fuse box and then to the brake lights in the back. the right rear turn should be on the dark green wire from the bcm to the drivers under seat module. It comes out as dark green from the module but it turns to a yellow wire at the light.

With the right turn signal turned on, does the front turn signal flash? If the front is flashing then you need to check the wiring at the BCM and see if it is sending the signal to the light in the rear. If the Bcm is sending out the signal to flash the light then follow the wiring until you lose the signal to find the open in the circuit. Or, check to make sure you have a good ground at the light socket.
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

Bigblocknut
Posts: 1
Joined: Fri Sep 29, 2017 3:36 pm

Re: rr brake & turn signal dont work

Unread post by Bigblocknut » Fri Sep 29, 2017 3:49 pm

Hello everyone one I'm first time user here so hope I'm doing everything right. I have a 2004 chevy express 3500 van and having a similar problem as one previously posted with signal and tidal light issues but I've checked fuses under hood and seat and all seam to be good . I see where there was talked about the BCM or there fuses and snot sure on the BCM itself being a issue or there's fuses as I checked them and all seem good. The problem started after I hooked LED. Lights up on my trailer and they all worked good but I did have to scratch around and clean the contacts on the trailer light plug was very dirty but after I did get them working and I noticed after everything was done I had no driver side rear signal or driver side brake light and the front signal blinks really fast. Any help or advice would be greatly appreciated. Thanks

User avatar
carriedi
Posts: 2295
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: rr brake & turn signal dont work

Unread post by carriedi » Sat Oct 07, 2017 12:26 am

so is the problem on the trailer lights or on the truck lights with the trailer not connected?
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

Deezonurchin

Re: rr brake & turn signal dont work

Unread post by Deezonurchin » Wed Mar 14, 2018 9:15 am

Thank you. With your help narrowed my problem down to fuse for BCM 6.

Guest

Re: rr brake & turn signal dont work

Unread post by Guest » Tue Jun 26, 2018 4:51 pm

Thank you bcm fuse 6 I had the same problem

Guest

Re: rr brake & turn signal dont work

Unread post by Guest » Sat Nov 02, 2019 2:06 pm

OMG had same problem. RR taillight out, third brake light out, front right blinking fast, left side working normal. It was bc6 10A fuse blown. Thank you.

User avatar
carriedi
Posts: 2295
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: rr brake & turn signal dont work

Unread post by carriedi » Sun Nov 03, 2019 6:07 pm

here's is a wiring diagram that shows all the fuses
Attachments
express tail light3.jpg

User avatar
carriedi
Posts: 2295
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: rr brake & turn signal dont work

Unread post by carriedi » Sat Jan 11, 2020 6:13 am

when one turn signal works and one doesn't it is usually the tail light contacts or the turn signal switch. If the front one works then usually the switch is working so verify the contacts for the light that is not working are all good. You're going to need a test light and check the turn signal wire at the rear brake light wire. It should be green to the tail light connector and then turn to yellow after the connector. If the switch is working there will be power to the wire. There might not be power at the bulb contact. you can buy new parts to replace the light socket parts

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post