Dodge Transmission valve body question

Ask our auto mechanics for help to all your Dodge and Chrysler questions.
Post Reply New Topic
mylesd
Posts: 1
Joined: Fri Jul 22, 2016 8:23 pm

Dodge Transmission valve body question

Unread post by mylesd » Fri Jul 22, 2016 8:28 pm

My car has the issue where it goes into limp mode due to code 1776 (L/R solenoid switch valve latched in closed/open position).....but only after warming up, driving for 20 mins or so. I'm very curious why it doesn't stick when its cold..never? Is it the valve/bore that has deteriorated OR the fluid (temp, cleanliness, chemical breakdown) that has occurred?

 

User avatar
carriedi
Posts: 2279
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: Dodge Transmission valve body question

Unread post by carriedi » Fri Jul 22, 2016 11:44 pm

I am not a tranny expert but...
it could be the valve bore is worn. it could also be debris in the fluid. The thing to check is drop the pan and see if there is debris in the pan. If you have debris in the pan you're probably looking at an replacement tranny. If there isn't much debris then a valve body replacement may take care of your trans. Depending on the year and stuff you may need a solenoid pack too.

temperature makes a difference in the fluid viscosity and also changes the clearances between the metal parts.

Check for trans TSB's for your year make and model. there are some that you check the production numbers for.
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post