All times are UTC - 6 hours [ DST ]




Ask A Question Reply    Go to page Previous  1, 2
Author Message
 

contributions: 2
I believe the speedometer/instrument panel is working correctly because the needle goes to zero when the ignition switch is turned off, plus on the recalibration sequence (holding down Trip and Reset buttons then turning on ignition switch) the needle seems to do exactly what it should. I believe it's getting a signal from the BCM or something to cause that reading when the switch is turned on.
The electronic reader for Chrysler (I forget the name) is very expensive for an individual to purchase.
I wonder if there is any resetting possible on the BCM without special equipment.
Leonard


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2256
Images: 37
Location: Oregon
most shops have scanners that can look at the vehicle speed and also scan the instrument cluster for codes.


   
Reply with quote  
 

contributions: 17
this may or may not help. I had the exact same problem with a 73 Chev Pkup that I had owned since new. At around 125,000 I backed it out of the drive, started up the street and it quit. DEAD turn over , no start no matter what. Now this was in the days before all this electronic stuff, so there wasnt a lot that could be wrong.
Towed it to my friends shop. Points Plugs condenser. Nothing. Wires. nothing. Nothing we did would make it start again, Pulled Distributor and on and on and on. Ok So I got mad and DECLARED, well at 125 it should be rebuilt anyway. Out comes the Engine, strip it, and send it to the machine shop. Get it back. assemble the engine, proudly install it, And VROOM starts. Run in the Cam and I figure we are almost there. Make the Exhaust connections... Wont start LMAO.

OK It must be a Plugged Muffler ! Off to buy a muffler..... Put it On...... NOPE! Now I m Insane. disconnect the exhaust pipes from their manifolds VROOMMM

Finally, upon taking a Sawzall to the crossover bend coming from the right exhaust manifold. There is a two or three layer section in there that I suppose keeps it from rusting out or burning out. That had somehow collapsed INSIDE the Pipe and Choked the system. Like ramming a potato up the exhaust pipe. The outside of the pipe looked perfectly normal. I SWEAR THIS IS TRUE! I showed it to some Pro mechanics and they were even baffled. I learned the expensive way about exhaust clogs and since i read about the glowing muffler etc, and you changed everything Maybe this would give you another idea.


   
Reply with quote  
 

contributions: 2
Re: 2008 T&C won't accelerate after dead battery/ jump start. What happened? Any good suggestions would be appreciated. Thanks


   
Reply with quote  
 
User avatar

contributions: 2256
Images: 37
Location: Oregon
sounds like you may have spiked your electrical system. Check what I said to do in your other posting


   
Reply with quote  
Ask A Question Reply    Go to page Previous  1, 2

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Chrysler Town and Country won't start

[ Go to page: 1, 2 ]

in Dodge And Chrysler

RANDALL25

10

4667

Mon Feb 15, 2016 9:37 pm

dw85745 View the latest

New Articles View the first 2003 town and Country driver's side window.

in Dodge And Chrysler

stevep

1

1547

Tue Dec 19, 2017 2:10 am

carriedi View the latest

New Articles View the first Attachment(s) 2005 lincoln town car headlight

in Ford Cars

lancer1945

4

2798

Thu Jan 12, 2017 5:24 am

Haggertyford86 View the latest

New Articles View the first Attachment(s) Is this a Chrysler Town & County Touring ?

in Dodge And Chrysler

zolahudson

1

1132

Sat Dec 31, 2016 9:40 pm

carriedi View the latest

New Articles View the first Just Stops running

in Ford Cars

wmona86

4

2446

Mon Dec 28, 2015 6:17 pm

carriedi View the latest

New Articles View the first 95' GMC G2500 5.7 won't stay running

in GMC Trucks

Beerstalker73

4

2803

Thu Sep 21, 2017 11:13 pm

carriedi View the latest

New Articles View the first Chevy Van Does not stay running

in Chevy HHR

Johnjohnson

5

2659

Tue Jan 05, 2016 11:06 am

tech3 View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us