2007 4 -Runner will not start

Ask our auto mechanics for help to all your Toyota questions.
User avatar
artmadrazo
Posts: 2
Joined: Wed Apr 17, 2013 9:25 pm

no engine start on Toyota truck

Unread post by artmadrazo » Wed Apr 17, 2013 9:33 pm

91 toyota truck won't start. there is spark, the engine is on timed and there is fuel pressure. When I spray starter fluid there is some combustion. I believe there is no fuel delievery from the Fuel injectors. what would cause that?
does it ever end?

 

User avatar
ProTech
Posts: 657
Joined: Wed Oct 17, 2012 10:08 am

Re: no engine start on Toyota truck

Unread post by ProTech » Thu Apr 18, 2013 6:35 pm

Did you actually do a fuel pressure check? If so, what was the reading?
GM Dealer Technician For 18+ Years
In the automotive industry for 20+

User avatar
artmadrazo
Posts: 2
Joined: Wed Apr 17, 2013 9:25 pm

Re: no engine start on Toyota truck

Unread post by artmadrazo » Fri Apr 19, 2013 10:07 am

No. I check for pressure at the cold cold start ejector. there was what I thought to be enough. What should the pessure be appox.
Thanks for reply

User avatar
ProTech
Posts: 657
Joined: Wed Oct 17, 2012 10:08 am

Re: no engine start on Toyota truck

Unread post by ProTech » Fri Apr 19, 2013 2:00 pm

Your truck is a bit too old for me to find an accurate fuel pressure spec. You might want to check with your local Toyota dealership. I sure wouldn't go off of looking at the cold start injector to verify fuel pressure. It may not be a fuel issue, but if it were me, I'd want to know for sure it's in spec before I go further, just to at least eliminate that as a cause.
GM Dealer Technician For 18+ Years
In the automotive industry for 20+

User avatar
carriedi
Posts: 2266
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: no engine start on Toyota truck

Unread post by carriedi » Mon Apr 22, 2013 1:35 am

33 to 37 psi with the vacuum line attached to regulator
38 to 44 psi with vacuum line disconnected and plugged off
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

jel75
Posts: 2
Joined: Sat Jun 29, 2013 12:59 pm

2007 4 -Runner will not start

Unread post by jel75 » Sat Jun 29, 2013 1:03 pm

I had to replace the marker light bulb on the driver side of a 2007 Toyota 4 Runner. To access the bukd, I had to remove the battery, After replacing the bulb and re-installing the battery, the car has no power, will not turn over at all. Any ideas?

User avatar
carriedi
Posts: 2266
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 2007 4 -Runner will not start

Unread post by carriedi » Sun Jun 30, 2013 1:44 am

are you sure you have a good clean connection at the battery terminals? Battery+ goes to the starter and to the engine room fuse and relay box. it splits in the box at a 140A alternator fuse.

Do you have no voltage anywhere in the vehicle? If the answer is "no" look at your battery connections. If you have some things that have power and some things do not: tell me what has power and what doesn't so I can look at the wiring diagram and see where the split looks like it's coming from.
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

jel75
Posts: 2
Joined: Sat Jun 29, 2013 12:59 pm

Re: 2007 4 -Runner will not start

Unread post by jel75 » Sun Jun 30, 2013 12:54 pm

There was a connection issue coming from the fuse box to the battery. Thanks for your help!

Tina
Posts: 1
Joined: Sun Feb 15, 2015 4:45 pm

2006 Toyota Sequioa

Unread post by Tina » Sun Feb 15, 2015 5:01 pm

what makes the trac, vac, and abs lights come on at the same time?

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post