93 f150 fuel problem need answers

Ask our auto mechanics for help to all your Ford truck questions now.
Taly
Posts: 5
Joined: Sun Feb 03, 2013 6:46 pm

1998 ford windstar vibration

Unread post by Taly » Sat Feb 09, 2013 4:07 pm

:) I'm fixing the 98 Ford Windstar minivan, when I go above 65 mph starts shaking but not the wheel but all full minivan, seats sound like a vibrator. can you tell me which part is corrupted, or needs to be replaced, the tire is spent every 3 or 4 months from new.

User avatar
ProTech
Posts: 633
Joined: Wed Oct 17, 2012 10:08 am

Re: 1998 ford windstar vibration

Unread post by ProTech » Sun Feb 10, 2013 8:13 pm

If the alignment is severely off, it can wear out tires rather quickly. That can be due something bent or loose or broken in the steering/suspension area such as a tie rod end, control arm, ball joint, strut, etc. I can't really tell you which part is bad since I'm not personally looking at the vehicle, but I would highly recommend getting the van checked over. At the very least you'll need an alignment, which you cannot do yourself.
GM Dealer Technician For 18+ Years
In the automotive industry for 20+

aron
Posts: 2
Joined: Wed Feb 13, 2013 7:10 am

Re: 1998 ford windstar vibration

Unread post by aron » Wed Feb 13, 2013 7:12 am

Excellent post. I want to thank you for this informative read, I really appreciate sharing this great post. Keep up your work. Thanks for this very useful
FSL:

blissfullymarried
Posts: 3
Joined: Sun Mar 31, 2013 5:58 pm

2003 expedition dvd help

Unread post by blissfullymarried » Fri Apr 05, 2013 2:46 am

Does anyone have any idea where the power button is for the factory dvd player is?

User avatar
TerryAuto
Posts: 308
Joined: Fri Dec 11, 2009 8:48 pm

Re: 2003 expedition dvd help

Unread post by TerryAuto » Fri Apr 05, 2013 11:57 pm

Not sure i uuderstand the question.
You cant turn the DVD screen on?
There is a button on the screen, use the remote or AUX on radio.

blissfullymarried
Posts: 3
Joined: Sun Mar 31, 2013 5:58 pm

Re: 2003 expedition dvd help

Unread post by blissfullymarried » Wed Apr 10, 2013 7:30 pm

yes I cant turn it on I can not find a power button anywhere. I do not have a remote

User avatar
carriedi
Posts: 2461
Joined: Wed Apr 10, 2013 12:42 pm

Re: 2003 expedition dvd help

Unread post by carriedi » Thu Apr 11, 2013 2:38 am

here's all the manual has to say:
• To disable the DVD player, simultaneously press the 3 and 5 memory
presets on the radio face. To enable the DVD player again, press the 3
and 5 presets simultaneously.

Drewh
Posts: 1
Joined: Sat Jan 28, 2017 5:23 pm

93 f150 fuel problem need answers

Unread post by Drewh » Sat Jan 28, 2017 5:29 pm

Have a 93 Ford f150 dual tanks had it running one day and the next day wouldn't start it's a fuel problem, none getting to the engine any suggestions

User avatar
carriedi
Posts: 2461
Joined: Wed Apr 10, 2013 12:42 pm

Re: 93 f150 fuel problem need answers

Unread post by carriedi » Sun Jan 29, 2017 3:10 pm

need more information. How do you know it's a fuel problem? What is the measured fuel pressure at the fuel rail? Both tanks won't work? Can you hear the fuel pumps run when you cycle the key? )Key on engine off) Do you have spark? do you have injector pulse? Will it run with an external fuel source?

you have dual tanks. each tank has it's own fuel pump. Power for both tanks goes through the inertia switch. Actually, it goes like this: power comes from fuse o in the engine compartment to the fuel pump relay (on a yellow wire). Next to the inertia switch (on a dark green and yellow wire). Then it goes to the fuel tank selector switch (on a red and yellow wire). From there it goes to the fuel pumps (red wire for the front tank and brown and white to the rear tank).

Andre

03 Ford expedition trac light

Unread post by Andre » Tue Nov 12, 2019 3:46 pm

I have 03 expedition and my traction control/stability light is flashing and I believe my 4x4 isn't working due to that. Now when I change it to 4x4L I do feel the vehicle jerk as it should but still doesn't feel like 4x4 is working properly because I'm still fish tailing....what can I do or fix

User avatar
carriedi
Posts: 2461
Joined: Wed Apr 10, 2013 12:42 pm

Re: 03 Ford expedition trac light

Unread post by carriedi » Tue Nov 12, 2019 10:07 pm

you should have your vehicle scanned to see if codes are stored that could be the cause of your problems. A wheel speed sensor may not be sending the correct signal. drive with the scanner monitoring the speed sensors and see it they all read the same speed with no signal drop outs.

you can scan the transfer case to check on the 4wd unit. Switches go bad, transfer case shift motors go bad could be vacuum line not passing vacuum or leaking vacuum.

  • Similar Topics
    Replies
    Views
    Last post