All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
I have changed the speed sensor and ,I have changed cluster and my speedometer still doesn't work can anyone help


   
Reply with quote  
* Search   
 
User avatar

contributions: 2275
Images: 37
Location: Oregon
you need to drive the vehicle with a scanner and read the VSS_GEM pid and see if it has the vehicle speed. If you do get a speed signal then you have to start checking wiring between the cluster and the gem module. is all the wiring all check out good, no shorts or opens, then you might need to replace the cluster


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first flasher relay Ford F250 Super Duty (2002)

in Ford Trucks

mulrich

1

1517

Sun Mar 10, 2013 8:12 pm

ProTech View the latest

New Articles View the first ac on my 99 f350 ford super duty diesel

in Ford Trucks

fgomes

1

2067

Sat Jul 05, 2014 10:37 pm

carriedi View the latest

New Articles View the first Ford F350 super duty 2002

in Ford Trucks

bjpw

1

1001

Fri Jun 29, 2018 12:18 am

carriedi View the latest

New Articles View the first air bag light flashes f-250 super duty

in Ford Trucks

johnsautos

1

1982

Fri May 17, 2013 8:56 pm

ProTech View the latest

New Articles View the first starting problems f 250 super duty 7.3 deisel

in Ford Trucks

johnsautos

1

1718

Thu May 16, 2013 6:28 pm

ProTech View the latest

New Articles View the first 2000 f250 5.4 4x4 won't engage

in Ford Trucks

Rockytruck

1

2400

Tue Dec 24, 2013 5:53 pm

carriedi View the latest

New Articles View the first 2000 ford ranger 4Wd

in Ford Trucks

darren1972

1

2241

Sat Apr 26, 2014 1:31 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us