All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
Put in 4 high light says in 4x4and will move but its not in 4x4 when put in 4 low its like putting truck in neutral is five speed with manual. Hubs don't matter what gear just revs but light stays on in either one like suppose to if it was workin any idea what it is


   
Reply with quote  
* Search   
 
User avatar

contributions: 2275
Images: 37
Location: Oregon
check for a vacuum leak


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Speedometer not working on my 2000 Ford F250 super duty five

in Ford Trucks

Testercst

1

3348

Wed Sep 30, 2015 5:06 pm

carriedi View the latest

New Articles View the first 1999 f250

in Ford Trucks

bubba189

1

1885

Mon Nov 17, 2014 9:22 pm

carriedi View the latest

New Articles View the first 2003 F250

in Ford Trucks

ChucksTruck

8

3955

Sat Nov 19, 2016 7:59 pm

carriedi View the latest

New Articles View the first 98 f250 EVAP system

in Ford Trucks

tec

1

1569

Tue May 28, 2013 4:36 pm

TerryAuto View the latest

New Articles View the first 2005 f250 5.4 litre reading hot

in Ford Trucks

stephson777

1

1714

Wed Jun 12, 2013 11:01 pm

carriedi View the latest

New Articles View the first 1990 F250 has fuel and spark will crank will not fire

in Ford Trucks

jeffw

3

1531

Mon Feb 11, 2013 9:52 pm

TerryAuto View the latest

New Articles View the first flasher relay Ford F250 Super Duty (2002)

in Ford Trucks

mulrich

1

1517

Sun Mar 10, 2013 8:12 pm

ProTech View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us