2000 ford expedition whine noise in steering

Ask our auto mechanics for help to all your Ford truck questions now.
Post Reply New Topic
savannah
Posts: 1
Joined: Thu Nov 14, 2013 8:34 am

2000 ford expedition whine noise in steering

Unread post by savannah » Thu Nov 14, 2013 8:39 am

I HAVE A 2000 FORD EXPEDITION. WHEN I TURN MY WHEEL (USE TO BE ONLY RIGHT, BUT NOW BOTH WAYS) SHARP/HARD I HEAR A BUILDING WHINE (OR SOME SORT OF NOISE) THEN IT POPS. NOT JUST THAT IT MAKES A POP NOISE I CAN FEEL IT POP. I HAVE CHANGED THE TRANSFER CASE AND CV AXLES PER PEOPLES OPINION. CV AXLE ON THE RIGHT WAS COMPLETELY MESSED UP. BUT MY PROBLEM IS NOT SOLVED. PLEEEEESE HELP :(

 

User avatar
carriedi
Posts: 2266
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 2000 ford expedition whine noise in steering

Unread post by carriedi » Thu Nov 14, 2013 5:21 pm

something like this will have to be looked by a mechanic. It could be a ball joint, it could be the transfer case magnet if it's AWD, it could be a frame or frame mount problem... Some one will have to be listening and maybe using a tool like the "Chassis ear" to locate the noise and diag the reason.
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

tncountryboy09
Posts: 1
Joined: Mon Jul 27, 2015 7:25 pm

Re: 2000 ford expedition whine noise in steering

Unread post by tncountryboy09 » Mon Jul 27, 2015 7:39 pm

i have a 2000 Ford Excursion 2 wheel drive, had a bearing go out, took it to mechanic because had no place to work on it, he replaced the bearing, then a few days later the same whining, rumbling noise came back, so took it back and the bearing was again seized, so i had a new spindle, rotor, and bearing put on, and again, a few days later same noise, any suggestions?

User avatar
carriedi
Posts: 2266
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 2000 ford expedition whine noise in steering

Unread post by carriedi » Tue Jul 28, 2015 11:20 pm

Unusual to have the same problem keep popping up like that. Pretty straight forward, bearing noise, replace bearings and seal. On a two wheel drive it's just an inner and outer bearing and a seal. (front wheel)

you have replaced the bearings, then the bearings and a spindle and the bearings are making noise again? Have you used the same hub and rotor every time? If every thing else has been changed and the problem keeps coming back I would try a new hub assembly. maybe there is something wrong with the hub. (what else is there?)
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post