2003 Ford expedition ABS and Advance Trac problems

Ask our auto mechanics for help to all your Ford truck questions now.
Post Reply New Topic
NiecyGirl
Posts: 1
Joined: Wed Dec 12, 2012 12:40 pm

2003 Ford expedition ABS and Advance Trac problems

Unread post by NiecyGirl » Wed Dec 12, 2012 12:48 pm

I am having ABS and Advance Trac problems. I read all the comments about it and noticed the normal braking is still active, but is this something I need to get look at anyway.

I have 2003 Ford Expedition Eddie Bauer with Advance Trac. The light for the Advance Trac comes on and the ABS light comes on. The lights normally comes on and then off after a few days, but not both are remaining on. Is this something minor or major? I am tired of looking at the light how can I make it go off. Please help. I want to sell it, but I want to fix this problem first.

 

User avatar
ProTech
Posts: 660
Joined: Wed Oct 17, 2012 10:08 am

Re: 2003 Ford expedition ABS and Advance Trac problems

Unread post by ProTech » Thu Dec 13, 2012 11:31 pm

The trac light will come on, as will the ABS light when there is a problem with the antilock brake system on the vehicle. This can be anything from a bad wheel speed sensor or hub, to a computer module or wiring issue.

I can't really give you an exact answer since I don't know the vehicle and haven't had it hooked up to a scanner to see what is going on. This will probably not be a cheap repair, though! There would be no way to get the lights to go off without fixing the problem correctly.
GM Dealer Technician For 18+ Years
In the automotive industry for 20+

lag
Posts: 1
Joined: Sat Aug 08, 2015 8:32 pm

Re: 2003 Ford expedition ABS and Advance Trac problems

Unread post by lag » Sat Aug 08, 2015 8:47 pm

2008 ford escape
abs light and traction light comes on while driving then engine bogs down for few seconds then drives ok. any probables?

User avatar
carriedi
Posts: 2267
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 2003 Ford expedition ABS and Advance Trac problems

Unread post by carriedi » Sat Aug 08, 2015 10:49 pm

possible wheel speed sensor problem? when the traction control and/or abs comes on the abs will hit the brake for a second which will add load to the engine. Scan the abs

bundy150
Posts: 1
Joined: Mon Sep 28, 2015 4:06 pm

2000 ford expidition xlt wont move

Unread post by bundy150 » Mon Sep 28, 2015 4:14 pm

I have a 2000 exposition that when I put it in any gear it won't move it feels like it wants to. This this truck has never had any hint of a problem with the transmission I was thinking that maybe it could be the four wheel drive selector switch or maybe the tranfer case pump. The truck still starts fine and it seems like it wants to go but it just won't. Please if u have any suggestions or have experienced this same problem and have fixed it let me know what u did to fix it or what I should do to fix it. On yeah I believe the engine is a 5.4 Triton. Thank u for any help u may give me.

User avatar
carriedi
Posts: 2267
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 2000 ford expidition xlt wont move

Unread post by carriedi » Mon Sep 28, 2015 8:11 pm

have you tried to put it in 4wd or 4wd low? If you turn it to 4wd, do the lights come on to say it is engaged? If the 4wd indicators light up normally then it is probably a trans problem. The transfer case would have the lights flash on and off if there was a code or a problem with it changing modes.

msangel81

Re: 2003 Ford expedition ABS and Advance Trac problems

Unread post by msangel81 » Wed Jan 11, 2017 9:30 am

2004 ford expedition eddie bauer abs light on and advtrac light blinking or flashing all the time traction control doesn't work three codes c2777,c2778,and c1998 what could this be

User avatar
carriedi
Posts: 2267
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 2003 Ford expedition ABS and Advance Trac problems

Unread post by carriedi » Wed Jan 11, 2017 2:25 pm

c1998 is a code for module calibration not complete. If you have erased codes (certain codes) the module will need to be calibrated.

c2777 and c2778 are for the sensor cluster. The computer sees a fault in the sensor cluster. There are some tests to do but the cluster is not a repairable item. If it has a bad part you have to replace the unit.

clear the codes and calibrate the module and see if codes return

Post Reply