All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
My Mercury 1997 CougarXR7 the windshield washer not working check fuse is ok.


   
Reply with quote  
* Search   
 
User avatar

contributions: 2275
Images: 37
Location: Oregon
you have an electric motor for your washer pump. it has one black wire (ground) and one black/white wire (power from switch) There is a washer relay in the integrated control module. It supplies the power to the washer motor. It uses the same fuse as the wiper motor so if the wipers work it's not the fuse. (you already know) The pumps go out quite often. it you unplug the pump and use a test light between the two wires in the harness connection you can turn on the washer pump and if the test light lights up the circuit is good, probably just a bad pump. If the test light doesn't light up you have a circuit problem. Now you have to check if you have a bad switch or maybe a bad module. But pump is more likely.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Attachment(s) Mercury cougar 1997 xr7

in Ford Cars

tomtom

1

2197

Sat Sep 07, 2013 3:09 pm

carriedi View the latest

New Articles View the first Mercury cougar-1999

in Ford Cars

Lyon007

1

658

Tue Jun 26, 2018 12:05 am

carriedi View the latest

New Articles View the first Mercury Cougar Clutch

in Ford Cars

lostyearsago

1

2106

Tue Jan 22, 2013 10:48 am

TerryAuto View the latest

New Articles View the first Attachment(s) 1993 Mercury Cougar XR-7 Turn Signal & Brake Light Issues?

in Ford Cars

1964prostreetelcamino

1

2363

Tue Jul 15, 2014 6:07 pm

carriedi View the latest

New Articles View the first 1997 mercury sable won't heat up

in Ford Cars

ksukid

1

2025

Mon Dec 17, 2012 1:07 am

Karl View the latest

New Articles View the first 1997 Mercury Sable Has no heat

in Ford Cars

ksukid

3

2221

Sun Jan 06, 2013 9:32 pm

ProTech View the latest

New Articles View the first Attachment(s) 1993 Mercury Sable - Turn Signals Not Working

in Ford Cars

zounds

7

3615

Wed Aug 07, 2013 10:10 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us