All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
When I start my Envoy in the morning the cruise doesn't work. After I shut it off and restart it cruise works fine. Same thing happens after it sits at work all day (13+ hrs). It is now becoming more prevalent and needs shut off and restarted more often which doesn't always fix the issue. I haven't found anyone else having this problem. Please help.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2218
Images: 37
Location: Oregon
probably going to need a scanner for this one.

the TAC module, the vehicle speed sensor, checking the PIDs for the cruise control. Cruise control inhibit history...

Do you have a light that comes on to tell you the cruise is turned on or do you have a light that only lights up if the cruise is engaged? Do the lights for the cruise work normally?


   
Reply with quote  
 

contributions: 2
Light on dash is on only when cruise is set. Yes cruise lights work normally.


   
Reply with quote  
 
User avatar

contributions: 2218
Images: 37
Location: Oregon
okay, so you need to use the scanner to see what is happening when it doesn't work. May have to use a lab scope to see if the button signals are all getting though to the cruise module. A worn contact could send intermittent signals. If the button contacts are all good then the things that keep the cruise working are the speed sensor signal, the brake pedal signal. The TAC controller and the pcm.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Cruise control not working 2004 Chevy Z71

in Chevy Suburban

drewstinson

1

1314

Wed Nov 25, 2015 11:02 pm

carriedi View the latest

New Articles View the first Gmc envoy

in GMC Trucks

Dwhid64

1

822

Fri Apr 06, 2018 9:34 am

carriedi View the latest

New Articles View the first 2002 Gmc Envoy No Start

in GMC Trucks

Jamesh

3

1444

Tue Sep 26, 2017 11:01 am

carriedi View the latest

New Articles View the first 1999 GMC Envoy won't start

in GMC Trucks

bjhatfi

5

2340

Fri Mar 17, 2017 1:34 am

carriedi View the latest

New Articles View the first 03 envoy. Thermostat OE temp

in GMC Trucks

Cbvansickle

4

2242

Tue Sep 15, 2015 12:46 pm

butchkaz View the latest

New Articles View the first 06 envoy idle problem

in GMC Trucks

Beginnermechanic

1

1798

Wed Mar 23, 2016 10:17 am

carriedi View the latest

New Articles View the first 04 gmc envoy code c0055

in GMC Trucks

Anthonystull

1

3481

Tue Jan 26, 2016 11:31 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us