2004 GMC Envoy HVAC fan settings

Ask our auto mechanics for help to all your GMC truck questions.
ladeerry
Posts: 1
Joined: Thu Dec 20, 2012 3:20 pm

GMC truck head lights go off

Unread post by ladeerry » Thu Dec 20, 2012 4:10 pm

what would be wrong with my truck when i go to dim my lights and i loose all my lights. Not the dash lights but head lights and the running lights still stay on, just no head lights then back to brights its ok again.

User avatar
ProTech
Posts: 651
Joined: Wed Oct 17, 2012 10:08 am

Re: GMC truck head lights go off

Unread post by ProTech » Thu Dec 20, 2012 8:27 pm

Probably a faulty headlamp switch.
GM Dealer Technician For 18+ Years
In the automotive industry for 20+

66hauler
Posts: 1
Joined: Sat Feb 09, 2013 1:42 pm

Rear wiper and defroster on 2004 Yukon XL Denali

Unread post by 66hauler » Sat Feb 09, 2013 1:45 pm

Both my rear defroster and wiper do not work. Fuses are good. Is there possibly a bad relay? Or a bad ground?

User avatar
ProTech
Posts: 651
Joined: Wed Oct 17, 2012 10:08 am

Re: Rear wiper and defroster on 2004 Yukon XL Denali

Unread post by ProTech » Sun Feb 10, 2013 8:18 pm

If both things are not working, you may be looking at a wiring issue going to the back liftgate. A very common problem is a wire breaking in the rubber pass-through between the body and liftgate from being bent back and forth over the years. You can check this pretty easily by pulling the boot out, and then checking the wiring harness. You might have to remove the tape from the harness to get a good look at it, but usually you can see if a wire is broken pretty quick.

If the wiring is not the problem, make sure both defroster terminals are still attached to the back glass, and then check to make sure you're getting power to that and to the rear wiper motor. This would require removal of the liftgate trim panel. You might just have separate problems with each, as well, such as a bad rear wiper motor and/or defroster. A few checks with a test light will find your problem easily.
GM Dealer Technician For 18+ Years
In the automotive industry for 20+

ksf1963
Posts: 1
Joined: Sun Nov 10, 2013 3:00 pm

2004 GMC Envoy HVAC fan settings

Unread post by ksf1963 » Sun Nov 10, 2013 3:07 pm

Three of the Five fan blowers setting don't work. When I push the A/C button the Envoy won't idle and stalls out.

User avatar
TerryAuto
Posts: 313
Joined: Fri Dec 11, 2009 8:48 pm

Re: 2004 GMC Envoy HVAC fan settings

Unread post by TerryAuto » Sun Nov 10, 2013 7:13 pm

You have two problems on your GMC.
1. For the blower motors speeds, most likely the blower resistor is burned up and maybe even the connector. See this link for explanation. Blower resistor and wiring
2. For the stalling out when the A/C is turned on, the throttle body is full of carbon and needs to be cleaned out. This is a common problem on the GMC Envoy and the Chevy Trailbazer. Trailblazer stalling

Post Reply

  • Similar Topics
    Replies
    Views
    Last post