2007 Envoy - Fault Codes

Ask our auto mechanics for help to all your GMC truck questions.
Post Reply New Topic
bfirming
Posts: 1
Joined: Wed Dec 05, 2012 4:23 pm

2007 Envoy - Fault Codes

Unread post by bfirming » Wed Dec 05, 2012 4:42 pm

The Check engine light came 'on' - P1400 - Cold Start Emmission Reduction Control System & P0506 - Idle Air control System Revolutions per min lower than expected displayed; along with a couple brake related codes: B0244 - ABS SWAS; U1026 - PWM Delivered Torque Malfunction; V1026 - Loss of C2 CAN w/ ATC

Once the throttle body was cleaned; I test drove the vehicle and the check engine light when out as expected.

My question is .... (that I don't feel any braking concerns with the vehicle or vehicle control - stability or otherwise. I know that some code require 'x' number of key starts before they clear.) Should I be concerned about the last (3) codes, clear them and wait for them to reappear again with another dash light or is there something I can check to verify anything needs to be serviced?

The engine light wouldn't come on for these fault codes rather it should be another service light. Currently, there isn't another dash light on since the throttle body was cleaned. Thank you for your reply.


User avatar
ProTech
Posts: 658
Joined: Wed Oct 17, 2012 10:08 am

Re: 2007 Envoy - Fault Codes

Unread post by ProTech » Thu Dec 06, 2012 7:23 pm

Yes, a good throttle cleaning can do wonders, can't it?! That will always take care of the P0506 code.

As for the other codes, I really don't see anything that needs much attention. Sometimes you can get the loss of communication codes by other modules glitching out or setting other codes like you had. Or, if you've pulled fuses, disconnected the battery, or have done a reset lately.

I would recommend to just continue driving it as normal and wait and see if anything re-emerges, but most likely it will not.
GM Dealer Technician For 18+ Years
In the automotive industry for 20+

SDTaylor
Posts: 1
Joined: Thu Sep 05, 2013 11:10 am

Re: 2007 Envoy - Fault Codes

Unread post by SDTaylor » Thu Sep 05, 2013 11:15 am

I was told by my mechanic that the P1400 code may also be caused by a lose gas cap.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post