All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 
96 jimmy 4.3 4X4 144k miles, I rebuilt the upper end both heads machined a 1000 miles ago, bought ebay used injector spider was clean and listed as tested good, all new cap, rotor, wires, and plugs. Started and ran good with no codes for about a 1000 miles now throws P0303 every time you drive it a while 20 miles or so. I can't believe the compression has changed it test good after the rebuild and the electric parts are 2 months old hard to believe they are failing so it leaves the injector spider
anyone tell me how to test the injector without having to pay for dealer visit. Any help would be great!


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
You should check to make to sure you have spark and compression first, since that is fairly easy to do. If that all checks ok, then you can proceed to checking fuel. The spider unit you've got was new for 1996 and changed from the 1995 and older central port injection spider. You have individually serviceable fuel injectors that are sequentially fired. If you have a proper scanner, and fuel pressure tester, you can try a fuel injector balance test to see if there is a difference on cylinder number 3 (P0303 code is a misfire on cylinder 3). If you can't do that test, you can try to ohm out each injector and see if there is a noticeable resistance difference. You probably have a bad injector, or some restriction heading into the poppet port of that cylinder. I would remove the spider and look for debris blocking the fuel path too. If the injector ends up being bad, it is fairly easy to change.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 06 envoy idle problem

in GMC Trucks

Beginnermechanic

1

1879

Wed Mar 23, 2016 10:17 am

carriedi View the latest

New Articles View the first Trailblazer Compression Problem

in Chevy Trailblazer

Fmcclure

1

587

Thu Nov 30, 2017 12:49 pm

carriedi View the latest

New Articles View the first Attachment(s) 2005 venture electrical problem

in Chevy Venture Van

jerrythompson

1

1852

Sun Oct 23, 2016 10:16 pm

carriedi View the latest

New Articles View the first 2000 Tahoe Transmission/TCase problem

in Chevy Tahoe

GhostTown80

1

1851

Tue Nov 08, 2016 12:44 am

carriedi View the latest

New Articles View the first wiring or connection problem battery discharge

in GMC Trucks

concord

3

1509

Sat Jun 04, 2016 12:26 pm

carriedi View the latest

New Articles View the first 95 Chevy Silverado Crazy Mil Light Problem

in Chevy Silverado

docclock

1

972

Fri Feb 24, 2017 11:45 am

carriedi View the latest

New Articles View the first driver side headlights dont work. wiring problem i think

in Chevy Trucks

Joshp

1

3082

Wed Oct 07, 2015 11:20 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us