2004 ford explorer

For Olds Aurora and Cutlass to the Alero and Delta 88.
Ask our auto mechanics for help to all your Oldsmobile car questions.
LaCosha

2004 ford explorer

Unread post by LaCosha » Sat May 15, 2021 2:16 pm

replaced Motor/Transmission it ran hot on me engine light was blinking and battery light came on I pulled over called Mechanic to tow it back to the shop he told me he broke a A/C hose and replaced it but idk it seemed like that was the issue but idk

User avatar
carriedi
Posts: 2446
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 2004 ford explorer

Unread post by carriedi » Sun May 16, 2021 2:01 am

a broken ac hose wouldn't normally cause the engine to over heat. Some times you could get an air pocket in the cooling system right after the engine has been replaced and it hasn't been purged yet. Once the cooling system circulates the air out it should be okay.

you say that it ran hot. How hot is that? Like 3/4 to the top? 100% to the top? Did the mechanic tell you what the check engine light come on for? (scanned it for codes) Or the battery light?

How is the explorer doing now? Is it still getting hot or is running normal now?

Let me know if you have any more problems

I am really happy to hear that you pulled over and had the vehicle towed back to the shop. Way better than most people that keep driving to either try and get home or try driving back to the shop and risk doing a lot more damage.

Hope you're good now

04 Ford explorer, how come this came out in the Oldsmobile section?

  • Similar Topics
    Replies
    Views
    Last post