All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
The van was fine, then a 30 mile trip turned it off. When restarted SIL came on then started flashing. P0303 code tested plug,wire ,coil all ok. Decided to test ICM it tested bad EST/Spout circuit is bad! New ICM installed, flashing SIL took new one for testing. Failed EST/Spout. How to test ECU, X7/X24 CKP, CMP sensors. Any other ideas? It's Mom's van and she is impatient! HELP PLEASE and Thanks


   
Reply with quote  
* Search   
 
User avatar

contributions: 2275
Images: 37
Location: Oregon
you got a P0303 the first time. What codes did you get after that? Did you look at the freeze frame information to see what the computer saw when it set the code? Like was the engine warmed up, was it under a load, how the fuel trims were...

Are you getting the check engine light coming on or are you feeling the engine misfire? You could have a coil, a wire of a plug that is breaking down under certain conditions that may not act up at idle. If you only have one code for misfire in cylinder #3, you could have a bad or dirty injector that isn't getting enough fuel into that cylinder.

need more information. what are the symptoms of your concern and what information can you get from your computer?


   
Reply with quote  
 

contributions: 1
Thanks for the greatest advices!


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2002 olds Silhouette

in Oldsmobile

Tbartif6

3

1907

Wed Mar 22, 2017 12:19 am

carriedi View the latest

New Articles View the first Olds Silhouette Climate Control System

in Oldsmobile

Jeri

1

1766

Sat Mar 12, 2016 1:57 pm

carriedi View the latest

New Articles View the first Attachment(s) Oil sending unit 2003 Olds Silhouette van location

in Oldsmobile

chevelle33

1

1710

Sun Feb 09, 2014 12:15 pm

carriedi View the latest

New Articles View the first 2002 Olds Silhouette Misfire code PO302

in Oldsmobile

bowtie

1

1771

Tue Sep 07, 2010 12:28 pm

MeccBoy View the latest

New Articles View the first 2001 olds silhouette making faint odd ding noise

in Oldsmobile

Doittoday

1

1168

Sat Jun 22, 2013 4:17 pm

TerryAuto View the latest

New Articles View the first 02 silhouette

in Oldsmobile

daniela19

5

1910

Mon Aug 25, 2014 10:22 pm

carriedi View the latest

New Articles View the first Silhouette won't crank

in Oldsmobile

prorig

6

3770

Tue Aug 24, 2010 11:15 pm

butchkaz View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us