All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 13
I have a 03 oldsmobile alero. I had the fuel pump replaced & was told it went out again, I see lots of people saying it might be the anti-theft system shutting it down. How can I do 2 fix this, or bypass the system? Fuel pump relay seems to be fine.


   
Reply with quote  
* Search   
 
User avatar

contributions: 2275
Images: 37
Location: Oregon
lets start with some information. what is your car doing? have you measured the fuel pressure? is the security light on or flashing?


   
Reply with quote  
 

contributions: 13
Fuel pressure was checked, everything was good, the mechanic brought the car to my mom at work, then it shut off on her on her way home. It won't start. Seems like when it sits awhile, hrs sometimes days, then it starts on 1st try. Don't know if anti-theft light flashes, I have 2 go get the car off the side of the road in the morning. Also recently had ignition switch replaced (Don't know if that might have anything to do with it).


   
Reply with quote  
 
User avatar

contributions: 2275
Images: 37
Location: Oregon
if the car is running fine when it is checked you might not see any problems. you need to check for problems while they are happening to make sure you are on the right track. Intermittent problems may be hard to track down at times.

Alero fuel pressure is 50-60psi for the 2.2L and 52-59psi for the 3.4L


   
Reply with quote  
 

contributions: 13
It cranked right up this morning. Security light was normal. Could be a manufacturer defect in the new fuel pump or wiring on the fuel pump. The new fuel pump came with a wiring harness because the guys at Advance said GM changed it for some issues. Might there be anything else in there I should check? Also we could not hear the fuel pump turn on when it would not crank, relay was fine, pressure was fine.

2003 Oldsmobile Alero 2.2L
I said anti-theft, but they are calling it the passlock sensor.


   
Reply with quote  
 
User avatar

contributions: 2275
Images: 37
Location: Oregon
when everything is working it is difficult to say what is the problem. need to check everything when it is not working. or see if any codes were stored in history or pending codes.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 96 pontiac sunfire anti theft switch

in Pontiac

stradley

1

3518

Sun Nov 18, 2012 10:13 pm

ProTech View the latest

New Articles View the first fuel system

in Pontiac Montana

saltyjim12345

1

1226

Fri Feb 23, 2018 9:30 pm

carriedi View the latest

New Articles View the first changed fuel pump and car ran for about a day

in Oldsmobile

dannyd1977

1

1331

Thu Dec 06, 2012 9:52 pm

ProTech View the latest

New Articles View the first help alero fuel pump not coming on

in Oldsmobile

edward

7

3775

Sat Apr 20, 2013 10:53 am

edward View the latest

New Articles View the first Fuel pump runs for 2 seconds, then shuts off.

in Pontiac Grand Am

hereintop

1

1499

Fri Aug 27, 2010 8:36 pm

Guest View the latest

New Articles View the first 2003 grand Prix: new fuel pump not working

[ Go to page: 1, 2 ]

in Pontiac Grand Prix

JimmyHelterbrand

13

3959

Wed Feb 06, 2013 8:21 pm

ProTech View the latest

New Articles View the first 1991 Stalling. Fuel Pump or Crank Sensor?

in Pontiac Grand Prix

Jerry

1

1974

Sat Feb 06, 2010 6:48 pm

Meccboy View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us