92 Oldsmobile 88 no spark

For Olds Aurora and Cutlass to the Alero and Delta 88.
Ask our auto mechanics for help to all your Oldsmobile car questions.
Post Reply New Topic
Muse2max
Posts: 1
Joined: Tue Jul 29, 2014 6:33 pm

92 Oldsmobile 88 no spark

Unread post by Muse2max » Tue Jul 29, 2014 6:43 pm

I have a 1992 Oldsmobile 88 Royale and I've changed the following trying to get the car to start: starter, crankshaft sensor, ignition coil pack, ICM, fuel pump. Then noticed constant, not blinking, SECURITY LIGHT. Well after changing the ignition switch and getting a new key made...we thought everything was good. I had to remove the key from the ignition switch for 30 seconds. Then tried to start it again, but The car turned over for about 2 seconds... Then would not start. It's getting fuel but no spark. Help.

 

User avatar
carriedi
Posts: 2267
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 92 Oldsmobile 88 no spark

Unread post by carriedi » Tue Jul 29, 2014 9:30 pm

if your security light is staying on you will need to address that first.

does your engine crank over every time? you say there is no spark but you have replaced the crank position sensor and the ignition module...

using an ohm meter you may want to verify the resistance of your key on the white/black wire and the purple/white wire at the passkey module. wiring problems are common.

when you say you changed the ignition switch do you mean the lock and tumbler or the electrical switch? the lock and tumbler, or the key and cylinder, has the wires that go to the passlock module. did you use the same resistor as the old key?
Attachments
94-88royale.jpg
94-88royale.jpg (183.33 KiB) Viewed 2090 times

Post Reply New Topic