2001 oldsmobile alero

For Olds Aurora and Cutlass to the Alero and Delta 88.
Ask our auto mechanics for help to all your Oldsmobile car questions.
Post Reply New Topic
Marty1965
Posts: 1
Joined: Sun May 18, 2014 9:53 pm

Oldsmobile Alero Dies out

Unread post by Marty1965 » Sun May 18, 2014 10:06 pm

My father-in-law just had the engine rebuilt in his 2001 Alero 3.4l(3400 SFI) and he was telling me the car dies whenever he puts the AC in max. When I looked inside his car, his instrument cluster was lit up like a Christmas tree! It looked like every trouble light was lit. When I hooked up my scan tool, I found DTC codes P1189, P0717, U1040, and U1000. I also found ABS codes C1225, C1226, C1236, C1254, and C1298. Anyone have any idea what happened? I told him to take the car back to the guys and let them figure it out but he said they don't know anything about this problem. I tried to erase the DTCs but they immediately came back the next time I started the engine. Thanks. P.S.- I can't find out what P0717 is.


User avatar
carriedi
Posts: 2265
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: Oldsmobile Alero Dies out

Unread post by carriedi » Mon May 19, 2014 4:53 am

well, first, p0717 is a trans code. Input speed sensor circuit no signal.

p1189 is for the oil pressure switch circuit

U1040 and c1298 are for communication errors or loss of communication for the brake module.

u1000 is for another communication loss

c1225 and c1226 are wheel speed sensors that aren't looking normal while driving.

c1254 is for abnormal shut down.

I would look to see if the people that installed the motor left something unplugged. of if they pinched a wire somewhere. But before you do that, ask your dad if all those lights were on before he had the motor worked on.

you can drive the car with the scanner plugged in and see what the wheel speed sensors look like as you drive down the road. (have someone drive while you look at the scanner and if you can, graph the wheel speed sensors) These codes will turn on the ABS light, traction control light, turn off the cruise control and maybe some other stuff.

The shop that put the engine back in should be looking at that oil pressure switch circuit. May affect the warranty

and look for the communication codes. make sure all the grounds are hooked up and have good contacts.
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

krispy24
Posts: 1
Joined: Sat Jun 28, 2014 8:10 pm

2001 oldsmobile alero

Unread post by krispy24 » Sat Jun 28, 2014 8:14 pm

Ok so I have a 2001 Oldsmobile alero. Tuesday I was driving and all of the dash lights and gauges went out and the radio stopped working, I hit a bump and everything came back on. Went home parked the car tried to start it a few hours later but all it would do is start and shut back off, after a few times worked fine. A little later went back out and it started just fine but nothing on the dash worked. The next day the same problem but later on that day it stopped working all together, the car starts but shuts back off after a few seconds. What could the problem be?

User avatar
carriedi
Posts: 2265
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 2001 oldsmobile alero

Unread post by carriedi » Sun Jun 29, 2014 1:59 am

you should have the ignition switch checked to see if there are contact problems. may need a new switch. have it checked when it is acting up
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post