All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
My 99 alero mass air flow sensor is throwing a code, but it works in my friends alero. So it's not the sensor itself. Is there a relay or fuse that could have gone out? Or do I just need to track down a wiring problem? The day it stopped working my temp gauge also stopped working.


   
Reply with quote  
* Search   
 
User avatar

contributions: 2275
Images: 37
Location: Oregon
what motor does your alero have? 3.4?

and what is the code number. there is a fuse for the MAF in the underhood fuse panel. PCM/IGN fuse, a 10 amp fuse. it powers up the pink wire to the MAF. (3.4L)


   
Reply with quote  
 

contributions: 2
It is the 3.4l. It's actually throwing the po118 code now


   
Reply with quote  
 
User avatar

contributions: 2275
Images: 37
Location: Oregon
p0118 is for your coolant sensor. your computer sees the sensor reading way too high (so that would be cold in temperature, like -40F) for 6 seconds. So, unless you live in Antarctica, your coolant temp is not working and that will make the computer dump too much gas into the engine. Make sure the coolant sensor is plugged in. see if the harness connector or the wiring harness is damaged. if everything looks good you may need a new coolant sensor.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 1998 Pontiac Montana (on/off heat and temp gauge up/down)

in Pontiac Montana

sh

1

1918

Sun Feb 14, 2010 10:10 pm

Bob4 View the latest

New Articles View the first 1999 Olds Cutlass temp gauge runs hot

in Oldsmobile

Crawdaddy74

1

1361

Fri Jan 03, 2014 2:44 am

carriedi View the latest

New Articles View the first Oldsmobile Alero 2001 has no heat problems

in Oldsmobile

drake

2

3674

Thu May 21, 2015 4:05 pm

Gerhard7 View the latest

New Articles View the first Pontiac Bonneville battery gauge drops

in Pontiac Bonneville

jean00

1

1628

Tue Jan 08, 2013 8:23 pm

ProTech View the latest

New Articles View the first 2005 Buick Rendezvous Gauge Cluster Issues

in Buick

rdzowner

3

4577

Sat Jan 01, 2011 2:33 pm

MeccBoy View the latest

New Articles View the first Fuel gauge issue on 1998 buick lesabre

in Buick

ejbrown4930

3

2123

Tue Aug 24, 2010 12:30 pm

Steppingin View the latest

New Articles View the first 2001 Aurora Temp Sensors

in Oldsmobile

KAR

1

1183

Fri Dec 20, 2013 6:42 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us