All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
I recently just changed out a battery in my 93 Cutlass and now all of a sudden i dont have dash , tail or head lights and i checked the fuses but they are fine this 93 cutlass has a 3100 v6 motor PLEASE HELP..


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2256
Images: 37
Location: Oregon
I would be checking out your headlight switch. the parking lights and the headlights use different fuses. verify that you have power coming up from the fuses to the headlight switch. then compare what the headlight switch is putting out to the taillights and what it is putting out to the headlights.

what kind od cutlass do you have? Ciera, supreme, cruiser???


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2005 Pontiac Vibe --No tail lights

in Pontiac

Kennetht

1

1691

Wed Aug 10, 2016 6:37 pm

carriedi View the latest

New Articles View the first Grand Prix engine stalls when turn on lights

in Pontiac Grand Prix

gunny

3

2798

Mon Nov 30, 2015 2:09 am

carriedi View the latest

New Articles View the first Main headlights in my 2004 Oldsmobile Alero wont work

in Oldsmobile

Ash

1

292

Sun Aug 05, 2018 1:47 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us