2004 chevy trailblazer

Post Reply New Topic
sbarrette
Posts: 1
Joined: Fri Oct 05, 2018 12:23 pm

2004 chevy trailblazer

Unread post by sbarrette » Fri Oct 05, 2018 12:55 pm

170,000 miles rough idle slightly but majorly when in gear. it throws codes but doesnt keep the codes. when holding the brakes at a light it surges sometimes. in park or neutral slight rough idle. the bolt on the cam shaft sensor is broke from former owner p0014 is one of the codes. but is not always being thrown. so i think it is possible that it is just the vibration of the motor and the movement of positon. but another is p0455. changed the gas cap. i ordered the motor mounts. do i have liquid filled mounts or do i have straight stiff mounts. excuse the naivete im new to this and a single mom. i am learning

 

User avatar
carriedi
Posts: 2279
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 2004 chevy trailblazer

Unread post by carriedi » Sat Oct 06, 2018 12:26 am

you may have to have your cam sensor scoped to see if it has a consistent waveform. maybe fixing the broken bolt could fix the cam code...

make sure you don't have a vacuum leak that can affect your idle and surging problem. Unmetered aid can cause symptoms like this. Check the fuel trims to see if they are running a little lean. I have a propane bottle that has a valve and hose on it that I can move around the engine and look for vacuum leaks. you can either listen and watch the engine for a change if the propane is sucked in or, for smaller leaks (this will work with smaller and larger leaks), graph the o2 sensors on a scanner while you move the propane wand around and watch for the o2 sensor to jump to rich.

p0455 could be a leak like the gas cap. any where in the system. vacuum switching valve not working correctly. the fuel tank vapor pressure sensor not working. A scanner can do some tests on the purge solenoid and vent valve while watching the pressure sensor and see if they are working correctly. A smoke machine can lightly pressurize the evap system and check for leaks.

it's going to be hard to diagnose these system codes and the symptoms you have without some specialized equipment. you might look for a shop that can work with you and do the diagnostics for you. If you do find a shop that will just do the diag, remember that even testing and find problems, that may not cure all your woes. Unless you get a code like "you oxygen sensor has stopped working, replace it" it means you have to do some research to find out what the codes is relating to.

but at least you could have a direction to go in instead of just guessing and trying parts. They cal that "shotgunning". throwing a bunch of parts at the vehicle and see if that can fix it. That can get way more expensive than spending some money on diagnostics. But, sometimes shotgunning works. I've done it before. you look at all the symptoms. you test all the circuits and systems. You follow all the diagnostic trees. and everything still checks out good. So, you have to trust your gut and try something that makes sense. Something that would affect all the symptoms you are having and try a part. Some parts have what they call "in spec failures" they test good but they aren't actually working right. They're just not out of spec...but bad.

let me know if you find out what happening or if you need something I can help you with.
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post