All times are UTC - 6 hours [ DST ]




Ask A Question Reply    Go to page Previous  1, 2
Author Message
 

contributions: 7
Images: 0
It's the c1500 ,5.7 ,4l60e tranny,just 2 wheel


   
Reply with quote  
* Search   
 
User avatar

contributions: 2270
Images: 37
Location: Oregon
see if this will help


Attachments:
trans top half.jpg
trans top half.jpg [ 201.44 KiB | Viewed 2428 times ]
trans bottom half.jpg
trans bottom half.jpg [ 244.53 KiB | Viewed 2428 times ]
   
Reply with quote  
 

contributions: 7
Images: 0
I'm going to print it now.thanks for your help.common problem ,many different solutions lol.I'm tracing wires for continuity


   
Reply with quote  
Ask A Question Reply    Go to page Previous  1, 2

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Attachment(s) 2005 venture electrical problem

in Chevy Venture Van

jerrythompson

1

3271

Sun Oct 23, 2016 10:16 pm

carriedi View the latest

New Articles View the first 88 f150 electrical no dash or ignition power

in Ford Trucks

paulaka223

3

3229

Sun Jul 10, 2016 2:32 am

carriedi View the latest

New Articles View the first Ford Freestar headlights washers dim electrical

in Ford Trucks

onefeather

2

2266

Mon Feb 08, 2016 7:01 pm

onefeather View the latest

New Articles View the first Attachment(s) Heater issues

in Buick

Noglory51491

4

2267

Wed Feb 03, 2016 5:58 pm

carriedi View the latest

New Articles View the first 2005 Chevy suburban 5.3l v8 misfire

in Chevy Suburban

Dmantooth

1

3057

Sun Jan 22, 2017 3:19 pm

carriedi View the latest

New Articles View the first 2009 Chevy Suburban 2500

in Chevy Suburban

Jen2u2

1

1750

Wed Oct 25, 2017 11:32 pm

carriedi View the latest

New Articles View the first 2000 suburban back ac not working

in Chevy Suburban

Angelicwhisp

1

2202

Tue Feb 21, 2017 11:50 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us