All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 5
1995 suburban 5.7L 4wd, (TBI,OBD1) lots of parts hung, no power, stalling. pressing throttle hard gives back fire throw throttle body.
ok, so i posted this in a different forum, got no replies, so i am just going to copy my previous posts in here, and then go from there.
lots of info. More then glad to upload video or pictures of any test, or what ever else, just tell me.
: new parts:
(coil, dizzy cap and rotor, ICM, spark wires and plugs) and also
Coolant Temperature Sensor
TPS
EGR valve ( the valve wasn't moving, or holding a vacuum, but appeared to be stuck closed)
egr solenoid.
MAP sensor ( had a crack in it, so i just replaced it)
PCV valve
fuel injectors ( new o-rings and washers on them)
fuel pressure regulator
fuel filter
fuel pump & strainer ( i was planing to do the pump this summer anyway, so it didn't go out in the winter)
fuel sending unit ( the fuel line on it broke when i was removing the fuel line from it to do the pump, so i had to replace it).

fuel pressure is good (14 psi, and stays same when throttle is pressed in park.)

* i'll edit this post to bring reverent info to the top*


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
 

contributions: 5
vacuum test, it started out steady at 17.5 inHg at idle, as the engine warmed up, it was at a steady 16 inHg.

when it was warm, and i snapped the throttle, it goes to 0 quickly, up to 17 inHg, then it sits at 15 for a couple seconds, slowly rising back up to 16 and remaining there.

i found out i can't snap the throttle to hard, or it back fires through the throttle body and stalls, or try's to stall, this seems important. ( so pressing the throttle quickly even in park will cause a pop and stall, this seems consistent with running lean i think)

anyway, as far as i can tell, the vacuum readings don't indicate a problem, is that correct?


   
Reply with quote  
 
User avatar

contributions: 2193
Images: 37
Location: Oregon
ok, you should check the basics, do you have spark, fuel pressure and injector pulse. From the list of parts you have already replaced, you would think fuel and spark would be good but, you should still verify it just to be sure. If you have the correct fuel pressure, you have good spark and fuel injector pulse but it still won't start, remove your oxygen sensor and crank the engine over. See if you have a plugged exhaust.


   
Reply with quote  
 

contributions: 5
carriedi wrote:
ok, you should check the basics, do you have spark, fuel pressure and injector pulse. From the list of parts you have already replaced, you would think fuel and spark would be good but, you should still verify it just to be sure. If you have the correct fuel pressure, you have good spark and fuel injector pulse but it still won't start, remove your oxygen sensor and crank the engine over. See if you have a plugged exhaust.


first off, it will start, and i can drive it around the a couple blocks, just "dogs" or basically no power, and trys to stall.

fuel is defiantly not an issue, my fuel pressure is solid 14 psi, and these trucks run at 11-15 psi. solid meaning the pressure is there even when you rev it.
spark shouldn't be a problem with what i replaced, but either way, it wouldn't back fire through the intake because it didn't have good spark.

i checked for clogged cat, it seemed to be clogged up bad, not alot of heat after the cat, i could touch the muffler with my hand after 10 min of idle.

so i took took the muffler off, and smashed the guts of the cat with a crow bar, and blow them out the pipe by reving it. it was revving up perfectly in park as i blew the bits out, thought i had it fixed for sure, the engine was very responsive to the throttle, no bogging or lag. hooked the muffler back up and took it for a spin, it was a little bit better, but still not drive-able ( no acceleration).

muffler got hot though this time, so the cat was defiantly ONE problem.

i unhooked the muffler and bungee'd it to the side (so the exhaust didn't enter the muffler, to see if the muffler was plugged with cat parts), still ran like shit, and i couldn't rev it up clean in the driveway this time, back to back firing through the intake.

i am going to double check that i knocked all of the cat guts out of it, and then replace the O2 sensor, because it seems like the car is going into O2 closed loop. there is defiantly a chance i smashed the O2 with my crow bar too tho.


   
Reply with quote  
 

contributions: 5
also, i think i can take my O2 sensor into menards, and get something with a barb that will thread into the O2,
if that is so, i'll thread in a barb, and put a vacuum line on it, and make sure there is 0 psi back pressure at the O2, makes sense to double check, right?


   
Reply with quote  
 

contributions: 5
one last thing, if i don't get this figured out soon here, i'll upload video's of how its acting up, and vacuum test / fuel test, and spark plug pics


   
Reply with quote  
 
User avatar

contributions: 2193
Images: 37
Location: Oregon
backfiring in the intake would be a symptom of a lean condition or ignition timing off. (worn cam, broken or weak valve springs... see if it is a certain cylinder or cylinders that is/are misfiring)

the O2 sensors going into closed loop is a good sign. Closed loop is when the computer goes into normal control mode. Open loop is when the computer is on standby. Either the engine is still warming up or the O2 sensors are inactive. If you have a scanner that can tell you you're in closed loop, what does it show the O2 sensors doing when you drive and have the problem happening? When you accelerate hard the O2 sensors should go rich.

have someone rev up the motor while you watch your egr valve. Sometimes the egr valve will open too early causing a vacuum leak at off idle. Here is an example of one egr valve that is extreme but it can cause problems. This one was externally broken but they can be internally compromised also (internally is more common) https://www.youtube.com/watch?v=07Xr3MuAtfI

You should have your engine put on an ignition scope and look at the firing pattern. The spark line may show you what cylinder is acting up and may show what part of the combustion is messed up. look for the secondary KV it takes to start the spark, the burn time for how the fuel is being burned and the coil oscillations to bring the coil back. You might also want to verify that the primary side is working normally. The pick up coil may get corroded and act up. The ignition module may have a bad connection. Some times the wires that go to the module can get broken or damaged. (using a vacuum pump tool on the vacuum advance will will let you advance the plate all the way while you watch the engine to see if it acts up)

lots to check but more checking could save money on parts.

exhaust back pressure should be below 3 at 2000 rpm. 0 to 1.5 at idle. (most cars and trucks, some specific vehicles may have more, but as a general rule...)


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Lots of issues with my 03 Saturn Ion 3 Sedan - automatic

in Saturn

ashleynmatzie

1

695

Thu Jul 20, 2017 10:38 pm

carriedi View the latest

New Articles View the first pt cruiser parts websites?

in All Other Car Questions

juan23

1

619

Wed Jun 22, 2016 11:00 am

carriedi View the latest

New Articles View the first f250 5.4 starts then stall no fuel , changed most fuel parts

in Ford Trucks

milkmandelight

4

1934

Sun Nov 13, 2016 12:09 am

Rachel View the latest

New Articles View the first Engine stalling

in Pontiac Grand Prix

FrustratedPrixowner

1

761

Sat Feb 04, 2017 3:04 pm

carriedi View the latest

New Articles View the first Saturn Vue stalling

in Saturn

Paulranha69

1

275

Mon Feb 12, 2018 12:12 pm

carriedi View the latest

New Articles View the first Ford e150 van Engine stalling

in Ford Trucks

sr069w

5

2092

Wed Apr 13, 2016 1:03 am

carriedi View the latest

New Articles View the first Honda Accord Jerking and stalling

in Honda

damionlillie23

2

1862

Sat Oct 21, 2017 7:57 am

Vugus View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us