92 Silverado K3500 7.4 L

stevep
Posts: 18
Joined: Wed Feb 11, 2015 8:44 pm

92 Silverado K3500 7.4 L

Unread post by stevep » Thu Oct 25, 2018 7:10 am

Ok... Uneven and sometimes surging at Idle. Smells very rich at start up. It will run at low RPM, but when Accelerator is pressed, falls on its face. Now after about ten minutes of nursing it up the hill to work... it will begin to run normally. I have changed Mass Air flow sensor, O2 Sensor, Therm Temp sensor, Another sensor that runs the cooler fan, and Finally The Throttle position Sensor. Only ting left is the EGR valve and many have told me to just clean it out with Carb cleaner and re install., which I have done. I did learn that Throttle Position sensor should be Calibrated ...LOL How the Hell does one accomplish that?
Any Help? You guys have always been great.

 

User avatar
carriedi
Posts: 2280
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 92 Silverado K3500 7.4 L

Unread post by carriedi » Thu Oct 25, 2018 8:59 pm

you have replaced a lot of parts. you should have the truck scanned to see what is really going on. See if there are any codes. Does the O2 sensor show rich or lean? Is it switching back and forth? what are the fuel trims? it will show you what the TPS is running at. with the scanner you can watch the wave form for the TPS and see it it is good at idle and watch the sweep from idle to full throttle with the key on and the engine off.

I would check and verify fuel pressure too. Could be the fuel pump is weak when cold and gets better as it warms up. (9 to 13 psi is spec)

check for vacuum leaks. Put vacuum to the egr valve and see if it causes the engine to stumble. If it does shut off the vacuum quickly. do that a few times to see if the egr valve is closing all the way. unplug the vacuum line, and plug it off, for the egr valve and drive it. still the same or not? if not check exhaust pack pressure. if the back pressure is ok and the egr valve is closed, then you should look for something else.

User avatar
carriedi
Posts: 2280
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 92 Silverado K3500 7.4 L

Unread post by carriedi » Fri Oct 26, 2018 6:20 am

also, check the distributor and cap for wear or damage. cracked magnet, bad module...

have you called any shops in your area to see if they could scan it for you?

Post Reply