1989 chevy ,350 bro 1500

Post Reply New Topic
Brucelenamond
Posts: 1
Joined: Thu Apr 12, 2018 6:12 pm

1989 chevy ,350 bro 1500

Unread post by Brucelenamond » Thu Apr 12, 2018 6:21 pm

I need help with my 89 c1500 extended can 2wd. I have changed the plug caps rotor and coil on my own... I am now having a problem cranking my truck it will not start but when I do eventually get it started it has trouble running it won't stay running and has a hard time moving like it's getting no gas I don't know what is wrong any help at all would be appreciated

 

User avatar
carriedi
Posts: 2279
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 1989 chevy ,350 bro 1500

Unread post by carriedi » Sun Apr 15, 2018 6:40 pm

if your truck was running okay before then I would double check the work that you did.

Gap the plugs at .035"

Make sure the spark plug wires are on the correct towers on the dist.

When you changed the cap did you take the ground strap from the old cap and put it in the new cap? It goes from one of the four screws that hold the coil in to the center pin where the electrical connector plugs into the Distributor cap.

There is no need to change the distributor timing so that should still be the same.

Let me know if it is not one of those things and I can tell you what you may need to check next.
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

dontnoshit

Re: 1989 chevy ,350 bro 1500

Unread post by dontnoshit » Sat Jun 23, 2018 2:52 am

sounds like to me u got ur wires crossed

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post