Chevy Truck only starts with stating fluid spray

Post Reply New Topic
cjargo72

2007 Silverado remote start problem

Unread post by cjargo72 » Mon Dec 28, 2009 12:29 pm

I have a 2007 Silverado. The engine light is on and the remote start has stopped working. Onstar diagnostics indicated that there was a problem with the emmissions system. Any suggestions?

 

Meccboy

Re: 2007 Silverado remote start problem

Unread post by Meccboy » Tue Dec 29, 2009 3:10 am

The reason for the remote starter not functioning is that the check engine light is on with a code.
There are many code, even for the emmissions system, that will cause the remote start to be dissabled.
Getting the check engine light code repaired and cleared will most definatley fix the remote start problem.

Blake

Chevy Truck only starts with stating fluid spray

Unread post by Blake » Sat Dec 29, 2012 4:29 pm

I have a 1988 Chevrolet c1500 pickup, 5.0Liter V-8 305 and It will not start without starting fluid. It has the following new parts: Ignition Control Module, Cap/Rotor, Spark Plugs, Fuel Pump (Now has an Inline Pump mounted on the frame rail), Fuel Filter, Vacuum Lines, Throttle Body/Fuel Injectors, and all wiring and fuses have been checked. If I turn the key the truck with turn over very smoothly but will not start, however I can spray a small amount of fluid and it will.

User avatar
ProTech
Posts: 657
Joined: Wed Oct 17, 2012 10:08 am

Re: Chevy Truck only starts with stating fluid spray

Unread post by ProTech » Sat Dec 29, 2012 9:35 pm

So does it stay running after you get it started with the starting fluid, or does it die out as soon as the starting fluid is used up?
GM Dealer Technician For 18+ Years
In the automotive industry for 20+

Blake

Re: Chevy Truck only starts with stating fluid spray

Unread post by Blake » Sun Dec 30, 2012 4:21 pm

The truck will stay running after a little starter fluid is sprayed. Then it runs and drivess fine until i shut it off again.

User avatar
ProTech
Posts: 657
Joined: Wed Oct 17, 2012 10:08 am

Re: Chevy Truck only starts with stating fluid spray

Unread post by ProTech » Sun Dec 30, 2012 7:55 pm

Ok, so then your problem is somewhere with the fuel delivery. Either you don't have a strong enough pump, or the wrong injectors. Usually it's a pump problem, either not enough pressure or volume. The amount of fuel needed to start the truck is not being delivered, but there is enough to keep it running after it's started with the starting fluid.

Seeing as how you put an inline pump on it, that is obviously not factory, you should check to make sure you have enough fuel pressure and/or volume. You may want to get rid of that pump if it's the problem and put a new factory pump back in the tank. Also, just some more information for you...if you left the old pump in the tank when you installed an inline pump, that's probably your problem. You need to put a different sending unit/pipe in the tank when you install an inline pump. Just FYI...
GM Dealer Technician For 18+ Years
In the automotive industry for 20+

Scottie

Re: Chevy Truck only starts with stating fluid spray

Unread post by Scottie » Sat Nov 11, 2017 12:22 pm

ACDelco 15-8240 GM Original Equipment Multi-Purpose Relay

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post