2002 Silverado 2500 Reverse quits working after heating up

Post Reply New Topic
Kimberlyjan
Posts: 2
Joined: Sat Nov 16, 2013 7:30 pm

2002 Silverado 2500 Reverse quits working after heating up

Unread post by Kimberlyjan » Sat Nov 16, 2013 7:36 pm

I just bought a 2002 Silverado 2500 and after I drive it a few miles the Reverse quits working. I can let the truck sit about 10 minutes and Reverse will work again, until it is driven again for a few miles. Could this be a sensor or ??????

User avatar
TerryAuto
Posts: 317
Joined: Fri Dec 11, 2009 8:48 pm

Re: 2002 Silverado 2500 Reverse quits working after heating

Unread post by TerryAuto » Sun Nov 17, 2013 4:20 pm

There is no sensor in the transmission that can prevent reverse. Sounds like you have an internal problem. Maybe a valve body problem. First try adding a cleaner then doing a trans fluid and filter change to see it that help. Put several miles on truck after adding the cleaner, before do the flush. Instructions are on the product that can be purchased at any parts store.

Kimberlyjan
Posts: 2
Joined: Sat Nov 16, 2013 7:30 pm

Re: 2002 Silverado 2500 Reverse quits working after heating

Unread post by Kimberlyjan » Sun Dec 01, 2013 9:20 am

Thank you for the info, but its not just the Reverse doing it now as I found out after a few driving attempts. Its the whole Transmission gets hot and starts slipping. After cooling off it works fine again.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post