00 1500 starts but wont stay running

upinstyle

1994 silverado idels but dies in gear and push gas

Unread post by upinstyle » Thu Jan 07, 2010 12:57 am

1994 silverado dies when put in gear and push the accelerator. Otherwise runs fine, it is a 5.7L vortec . Have changed almost everything (complete tuneup} plus the throttle possession sensor. The funny thing is that is the code it is reading. I have put 2 new ones on it, checked all the wiring and plugs to it. I have one person telling me it could be the MAS or the pick up coil. Any ideas?

 

Meccboy

Re: 1994 silverado idels but dies in gear and push gas

Unread post by Meccboy » Thu Jan 07, 2010 8:30 pm

You can unplug the MAF to see if that helps.
If the TPS codes comes back, must be a problem in the circuit.
Loss of 5 volt reference from ECM, or open wire for TPS signal to the ECM.

garbet

1999 Chevy Silverado Looses Power

Unread post by garbet » Sun Feb 07, 2010 2:35 pm

this truck is a v-8, power goes out totally. have checked batt. termanals and ground strap. it will repower and start go 30 ft. or 30 mi. before cutting out again.

meccboy

Re: 99 silverado

Unread post by meccboy » Mon Feb 08, 2010 12:11 pm

Could be a lot of things.
If you are loosing electrical power, there are many grounds on the engine. Check all wiring by pulling on engine harnesses when running.
Possible ignition switch. The ignition switch feeds power to most of the trucks electrical systems.

cjschmoldt

97 Silverado power loss

Unread post by cjschmoldt » Mon Mar 29, 2010 5:57 am

My truck has little power and bogs down when I try to accelerate, especially quickly. Have replaced the cap, wires, rotor, plugs, fuel filter, O2 sensor, and catalytic converters with no improvment.

Meccboy

Re: 97 Silverado power loss

Unread post by Meccboy » Mon Mar 29, 2010 3:58 pm

Check fuel pressure. Low pressure will cause no power.
Possibly jumped time.
If a V8, unplug MAF sensor and see if it improves.

Toby14

Re: 99 silverado

Unread post by Toby14 » Fri Nov 05, 2010 9:37 pm

If you are sure there are no problems with the battery cables or grounds, I would continue moving around engine wiring harnesses while the truck is running to see if you can get to act up. If this turns up nothing, then I would suspect a bad ignition switch. This is of course if you are referring to losing all electrical power and not engine power. The ignition switch feeds power to many if not most of the trucks electrical systems. Sometimes tapping on the head of the key or the underside of the steering column near the ignition while the truck is running will cause a faulty switch to act up. Also tilt the steering wheel up and down slowly and see if anything happens. If it does then you need to check the wiring in steering column from the ignition switch to the main – harness connector at the base of the steering column. You could have one of the power wires shorting out on one of the metal braces under the column under the dash.

mark

water in gas on 2003 silverado

Unread post by mark » Sat Jan 29, 2011 12:27 pm

Got water in gas, changed filter and truck wont start

AStallmag

Re: water in gas on 2003 silverado

Unread post by AStallmag » Thu Feb 03, 2011 12:14 am

May have plugged fuel injectors or a bad fuel pump. Need to check fuel pressure first.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post