Chevy Astro Won't start

Post Reply New Topic
cueball52902

Engine misfire

Unread post by cueball52902 » Sat May 22, 2010 7:58 am

Ran my motor while overheated for a short time due to busted hose and before motor died(with service engine soon light came on) it started to sputter and lost power until it stalled...engine restarted fine after "duct" taped hose as a temporary fixed and added water to radiator but run like engine is missing and won't idle ... Where do I start to begin the repair work?

 

Tom90

Re: Engine misfire

Unread post by Tom90 » Sat May 22, 2010 11:41 pm

Ckeck all the plug wires to see if any are burned.
If the engine overheated enough to cause the truck to stall out, then you may have blown a headgaket.
I would suggest removing the plugs asd look for signs of burning coolant.
While the plugs are out, have a compression test done as well.

User avatar
wildman
Posts: 49
Joined: Tue Aug 03, 2010 10:00 pm

Re: Engine misfire

Unread post by wildman » Tue Aug 03, 2010 11:07 pm

Unfortunately, running a motor till it heats up enough to sieze isn't good for it. Chances are you either took the temper out of the rings or blew/cracked/warped the head. The quickest way to check for a bad head is by removing the oil cap and looking for light brown or white foam on the inside of it. This will tell you @ 75% of the time if it's a head- but sometimes it does blow between cylinders and not put water in the oil. A compression test would check for that though.
If it's just the head, I would suggest having it planed flat or at least checked. But I haven't had much luck with vehicles run that hot- wish the best for yours though :)
Shade-tree mechanic

Did You Find Some Great Help?
Why make a small tip / donation to show your appreciation-
Help Keep Us Free

rugboy15
Posts: 1
Joined: Sat Dec 28, 2013 9:08 pm

Chevy Astro Won't start

Unread post by rugboy15 » Sat Dec 28, 2013 10:01 pm

My astro van has been running good until a couple days ago when i went to start it and it just cranked. It tried to start but never got running. It is getting spark and fuel. i can smell gas after trying to start it. I tried changing the plugs and wires and the plugs were soaked with gas. There are no codes showing. Any ideas of what i can try?

User avatar
TerryAuto
Posts: 317
Joined: Fri Dec 11, 2009 8:48 pm

Re: Chevy Astro Won't start

Unread post by TerryAuto » Sun Dec 29, 2013 8:07 pm

If it has been wet or damp out, remove the distributor cap and look inside for any signs of corrosion on the center rotor button or any of the spark plug wire terminals. These caps has a problem with dampness. It makes the spark jump around to the wrong spark plug wire terminal at the wrong time. Basically the spark is out of time. If you see some corrosion, or even not, I would replace the cal and rotor.

Also, you will need a fuel pressure gauge to check for pressure leaking down. That would be the sign of a sticking open injector or leaking fuel pressure regulator.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post