All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
First, I hope everyone that drives a GM, your cars run like they just left the assembly line. Mine is in a comma. It all started with code p0016, a loud (tick-tick-tick or clunk-clunk-clunk noise) and now it stalled on me. It is a 3.5L, K, flex fuel, v6, with 138,000 miles. 2 years ago when the car had 102,000 it threw code p0011 and one mechanic replaced the camshaft position sensor, camshaft actuator, and camshaft actuator magnet (the round piece of plastic with three screws and a connector). Replaced also the timing chain tensioner, but he kept the timing chain and crank sprocket. Is the new problem related to the old problem? Do I need a new camshaft or crankshaft? Or do I need a new timing set (camshaft actuator, camshaft actuator magnet, chain, sprocket, tensioner) and I am good? Please be as detailed as possible?

thanks,
Andre


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 319
Images: 4
So, does your car start and run?


   
Reply with quote  
 

contributions: 2
Terry-- My car does not run at the moment. The engine sounds like it won't crank or turn over.


   
Reply with quote  
 
User avatar

contributions: 319
Images: 4
If the engine will not start and you have timing sensor codes, it sounds like the timing chain or tensioner has broke. A ticking noise then a clunk is never good and is for sure not a sensor problem. Your car has a mechanical problem. You would need to check the engine timing to see if something jumped or broke. An experienced mechanic would be able to tell if the engine is out of time by listening to it as it is cranking and not starting.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 06 impala 3.5

in Chevy Cars

Jeremy

5

980

Tue Oct 10, 2017 12:05 am

carriedi View the latest

New Articles View the first 06 impala 3.5

in Chevy Cars

Jeremy

1

664

Sat Apr 29, 2017 12:54 am

carriedi View the latest

New Articles View the first Attachment(s) 2006 CHEVY OPTRA (P0454, THEN P0452)

in Chevy Cars

CanAm58

3

942

Sat Sep 16, 2017 3:27 am

carriedi View the latest

New Articles View the first 2006 Chevy Uplander Wont Start

in Chevy Trucks

jloper68

1

187

Mon Jan 29, 2018 1:58 am

carriedi View the latest

New Articles View the first 2006 Suburban 4wd Z71 Service stability code C0131

[ Go to page: 1, 2 ]

in Chevy Suburban

mike6w

8

3362

Tue Nov 03, 2015 11:43 am

carriedi View the latest

New Articles View the first 2016 Chevy Impala LT

in Chevy Cars

duramaxff16

1

248

Tue Jan 23, 2018 6:00 am

carriedi View the latest

New Articles View the first 2016 Chevy Impala LT

in Chevy Cars

duramaxff16

1

215

Fri Jan 12, 2018 2:12 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us