GreatAutoHelp.com Car Forums
http://www.greatautohelp.com:443/forums/

p0010 2006 Chevy Impala
http://www.greatautohelp.com:443/forums/viewtopic.php?f=3&t=5435
Page 1 of 1

Author:  cabby022 [ Sun May 12, 2013 2:07 pm ]
p0010 2006 Chevy Impala

2006 Impala 3.9, p0010 DTC, Camshaft Position Actuator ABank-1, I replaced camshaft position sensor, checked wiring and harness,ok, changed oil, clear code, its back on on at start up, any ideas ? Mike

Author:  ProTech [ Sun May 12, 2013 5:57 pm ]
Re: p0010 2006 Chevy Impala

This is fairly common and luckily a pretty easy fix. What you need to do is change the cam position actuator magnet that is located on the front of the engine. It looks like a large black triangle with a connector coming out the side of it. There are three torx screws that hold it on. Easy to replace....but...you need to check the following. There is a small 'button' that rides between the camshaft and the magnet. Once the magnet is removed, you should be able to push the button in on the timing gear and have it pop back out. If it does not, then you're looking at having to replace the camshaft and the timing gear set. This is very rare, so you'll most likely be good with just replacing the magnet, but just wanted you to know the details of everything involved.

Author:  cabby022 [ Tue May 14, 2013 10:59 am ]
Re: p0010 2006 Chevy Impala

Thanks I will try that, great help.

Author:  cabby022 [ Tue May 14, 2013 2:50 pm ]
Re: p0010 2006 Chevy Impala Picture

Any pics or diagram as to exact location would be great, thanks, Mike

Author:  ProTech [ Tue May 14, 2013 9:56 pm ]
Re: p0010 2006 Chevy Impala

See other post...I explained where it is...it should stand out like a sore thumb!

Author:  cabby022 [ Tue Jun 04, 2013 4:47 pm ]
Re: p0010 2006 Chevy Impala

Okay i ordered and changed the magnet like u said very easy, cleared code, stupid thing is back, what else ecm ?

Author:  cabby022 [ Thu Jun 06, 2013 4:00 pm ]
Re: p0010 2006 Chevy Impala

Problem solved, after getting the car up on a hoist, i found that the plug that goes into the magnet had bare wires touching, after repairing that, i cleared the code and it never came back, Thanks for all the help.

Author:  Qjboy [ Mon Dec 04, 2017 8:59 pm ]
Re: p0010 2006 Chevy Impala

Where does that wire go that plugs into the magnet can you get to it without a shop lift??

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/