2000 chevy impala wont start- instrument panel goes off

From the Chevy Cavalier and Monte Carlo to the Malibu, Lumina and Impala.
Ask our auto mechanics for help to all your Chevrolet car questions now.
Post Reply New Topic
morrilldaniels
Posts: 4
Joined: Thu Dec 27, 2012 7:19 pm

2000 chevy impala wont start- instrument panel goes off

Unread post by morrilldaniels » Thu Dec 27, 2012 7:31 pm

Engine had a period of shuting off for no reason. now will not start only sputters. The insturments will come on for just a second or so. The only code is loss of communication with insturments.

User avatar
TerryAuto
Posts: 317
Joined: Fri Dec 11, 2009 8:48 pm

Re: 2000 chevy impala

Unread post by TerryAuto » Thu Dec 27, 2012 11:46 pm

Is the loss of communication code with the instrument panel in the powertrain or body computer?
What is the actual code number?
Any other strange electical problems?
Any work done to try to repair the problem yet?
I will try to be of some help.
Be sure to check the Similar Topics down this page for more help.

morrilldaniels
Posts: 4
Joined: Thu Dec 27, 2012 7:19 pm

Re: 2000 chevy impala

Unread post by morrilldaniels » Fri Dec 28, 2012 2:34 pm

I rescaned car and found current code B2958. then history codes U1016, U1255, B2618,B2655 and B2958. PCM had history code P1626C. No current codes. I have been tryiny to start car since clearing codes a few days ago. Car has normal fuel pressure and seems to have spark.

User avatar
TerryAuto
Posts: 317
Joined: Fri Dec 11, 2009 8:48 pm

Re: 2000 chevy impala

Unread post by TerryAuto » Fri Dec 28, 2012 5:16 pm

OK. The B2958 and P1626 are related to the security. Do you have an aftermarket alarm or remote start on your Impala?
Be sure to check the Similar Topics down this page for more help.

morrilldaniels
Posts: 4
Joined: Thu Dec 27, 2012 7:19 pm

Re: 2000 chevy impala

Unread post by morrilldaniels » Fri Dec 28, 2012 6:13 pm

It does not have remote start. I think the alarm is original. My son purchased this car a few months ago. It was having the dieing issue when he got it

User avatar
TerryAuto
Posts: 317
Joined: Fri Dec 11, 2009 8:48 pm

Re: 2000 chevy impala

Unread post by TerryAuto » Fri Dec 28, 2012 8:31 pm

OK. A few possibilities...
1. The Body Control Module (BCM) is bad. That would explain the communication codes, and possibly the theft codes.
2. More common, the passlock cylinder is bad. This is the actual ignition key cylinder. It has the sensor for the theft system in it. This is very common for the B2958 and P1626 codes. First i would suggest doing a relearn procedure for the theft. There is a link to that procedure on this page- Chevy Impala Theft Learn
3. The ignition switch is bad. The above passlock sensor cannot cause the car to stall, but will cause it to not start. The ignition switch can do both. There is a picture of this parts on the link i posted above.
Be sure to check the Similar Topics down this page for more help.

morrilldaniels
Posts: 4
Joined: Thu Dec 27, 2012 7:19 pm

Re: 2000 chevy impala wont start- instrument panel goes off

Unread post by morrilldaniels » Sun Jan 13, 2013 9:06 am

sorry I didn't get back sooner. I removed the ignition switch and removed the back cover on it. One of the contacts was a little sooty and two looked like they were not alined very well. I cleaned the contacts put it back together and the car started instantly. Knowing that cleaning contacts sometimes does not last a long time I replaced the switch. The car has ran about 500 miles with many start up cycles and no codes and no check engine light. Now it has refused to start again and I have not had time to change the switch again.

User avatar
TerryAuto
Posts: 317
Joined: Fri Dec 11, 2009 8:48 pm

Re: 2000 chevy impala wont start- instrument panel goes off

Unread post by TerryAuto » Sun Jan 13, 2013 1:19 pm

Well, i woud not change the switch again. Did you look closely at the terminals on the ignition switch connectors? Sometimes they will show signs of burning or corrosion.
It seems the replacement fixed something, i mean, it started right up and was fine for a while. You may have had 2 problems.
Scan for codes and see if any of them came back.
Is this the 3.4L or 3800 engine?
Be sure to check the Similar Topics down this page for more help.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post