Loss of power on warm restart

Post Reply New Topic
bgood64
Posts: 3
Joined: Wed Sep 16, 2015 3:08 pm

Loss of power on warm restart

Unread post by bgood64 » Mon Apr 04, 2016 11:51 am

I have a 2000 Grand Prix, 3.8. When I turn the car off and try and restart it 10-15 minutes later, it runs extremely rough until I can get it into gear and step on the gas to clear it out. I have a noticeable reduction in MPG since having this problem.

 

User avatar
TerryAuto
Posts: 317
Joined: Fri Dec 11, 2009 8:48 pm

Re: Loss of power on warm restart

Unread post by TerryAuto » Wed Apr 06, 2016 9:54 pm

Sounds like you have a leaking fuel pressure regulator. See this link for more info..
https://www.greatautohelp.com/inspectio ... ator1.html

bgood64
Posts: 3
Joined: Wed Sep 16, 2015 3:08 pm

Re: Loss of power on warm restart

Unread post by bgood64 » Fri May 27, 2016 9:38 am

Replaced regulator and hasn't corrected problem. Ran ok for a couple of weeks, though no noticeable increase in MPG and still some rough idle on a hot restart. Now its abandoned me beside the road with it's rough idle, won't clear out.

User avatar
carriedi
Posts: 2266
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: Loss of power on warm restart

Unread post by carriedi » Fri May 27, 2016 10:55 am

is the check engine light on? If it is on, did you check to see what your codes are?

you may need a scanner to look deeper into your problem. Look for the misfire counter and see how the engine is doing. Is there one or more cylinders that the computer is seeing as misfires? Then you can narrow down on what to look for, spark, fuel injector, fuel pressure, compression...
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post