my 99 buick lasabre

Buick Regal, Century and Park Avenue as well as the Rendezvous and Lesabre.
Ask our auto mechanics for help to all your Buick questions now.
Post Reply New Topic
joe
Posts: 3
Joined: Mon May 06, 2013 6:52 am

Headlights and driving lights not working

Unread post by joe » Tue Mar 25, 2014 7:15 pm

I have a 2003 Buick Century. My driving lights and headlights do not work. I have tail lights, stop lights and parking lamps.

 

User avatar
carriedi
Posts: 2278
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: Headlights and driving lights not working

Unread post by carriedi » Wed Mar 26, 2014 3:28 am

you should check that your headlight fuses (HDLP L and HDLP R, both are 15A fuses in the fuse box by the right strut tower) are good and also check the headlight relay behind the glove box. you could also scan the body control module for the lighting too.

can you flash the high beams with the high/low switch? you might want to check the voltage on the yellow wire from the headlight switch.
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

joe
Posts: 3
Joined: Mon May 06, 2013 6:52 am

Re: Headlights and driving lights not working

Unread post by joe » Wed Mar 26, 2014 7:32 am

Yes, I can flash the high beams with the hi-low switch.

User avatar
carriedi
Posts: 2278
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: Headlights and driving lights not working

Unread post by carriedi » Wed Mar 26, 2014 11:30 am

then you should look at the headlight switch, relay and the BCM
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

continental67
Posts: 2
Joined: Fri Mar 03, 2017 7:02 pm

my 99 buick lasabre

Unread post by continental67 » Fri Mar 03, 2017 7:18 pm

installed new MAF today hoping it would clear problem of staling but it did not. auto zone checked error codes p1676. where is this part located on my car thank you for the help. is it a complicated task?

continental67
Posts: 2
Joined: Fri Mar 03, 2017 7:02 pm

99 buick lasabre

Unread post by continental67 » Fri Mar 03, 2017 7:22 pm

also rpms also are erratic tranny shutters when I start again.

User avatar
carriedi
Posts: 2278
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: my 99 buick lasabre

Unread post by carriedi » Wed Mar 08, 2017 2:09 am

I don't know what the history on your car is but the code is for the evap canister purge valve located on the top of the engine on the intake manifold.
Attachments
purge solenoid.jpg
purge solenoid.jpg (21.07 KiB) Viewed 4179 times
Browse "SIMILAR TOPICS" At The Bottom Of This Page.

Post Reply New Topic
  • Similar Topics
    Replies
    Views
    Last post