All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
I have a 2003 Buick Century 3.1 L engine with 49K miles, has been running great until the other day, went to the store came home everything was fine, but when it was put into park it rev'ed slightly then started Idling very rough, and knocking..
I have replaced the EGR Valve, The Plenum Gasket, Plugs, wires, and all 3 Ign. coils.
I've checked vacuum hoses, fuses, and various connections.
I got rid of the EGR code but still have the P0300 code of Engine Misfire, any ideas what to check? keep in mind everything has been FINE up too when it was put into park the other day, and yes it has not moved since, still idling rough and knocking.....HELP!!! Rick Maxwell Goodyear, AZ.

Also there has been NO Overheating Issues, and Oil is Changed every 3K


   
Reply with quote  
* Search   
 
User avatar

contributions: 2265
Images: 37
Location: Oregon
you should have it scanned for misfire counter and see what cylinders are affected. Once you can see how many and which cylinders are misfiring you can determine what direction you should go


   
Reply with quote  
 
The knocking sound very well could be a flywheel/flex plate but it should rap at idle. Mine was rapping and thought is was the bottom end of the motor. Sounded very similar. Whats stumping me is it don't do it at idle. I'm guessing the torque converter or transmission. The check engine light never came on?

________________________
https://towinglexington.com/


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Rough idle - codes listed

in Buick

Digitaldad143

1

2368

Sun Jan 31, 2016 12:52 pm

carriedi View the latest

New Articles View the first how to get a smooth idle

in Buick

SHOOTER

2

2132

Sun Oct 02, 2016 6:12 pm

SHOOTER1 View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us