All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
I have no speedo gas gauge works I checked for power to the plug switch that goes to the transmission no power? Please help!!


   
Reply with quote  
* Search   
 
User avatar

contributions: 2265
Images: 37
Location: Oregon
you need to see if the computer sees the speed sensor. You should get a scanner and see if it has the data from the speed sensor. If the speed sensor shows the actual speed then the problem is in the Instrument cluster. If there is no speed reading then look at the speed sensor and what makes it work for the problem


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2003 Buick Rendezvous over heating

in Buick

TSaldana

1

2998

Tue Feb 16, 2016 3:31 am

carriedi View the latest

New Articles View the first Attachment(s) 2002 Rendezvous- Shifter slides... Stuck in park.

in Buick

jsand100

3

3205

Sun Feb 21, 2016 9:51 pm

carriedi View the latest

New Articles View the first 2005 won't accelerate

in Buick

Rblumke123

2

2662

Sat Mar 25, 2017 6:00 pm

Brennanburg View the latest

New Articles View the first Attachment(s) my 99 buick lasabre

in Buick

continental67

2

3921

Wed Mar 08, 2017 2:09 am

carriedi View the latest

New Articles View the first 97 Buick lasabre

in Buick

BrokewithcarproblemsHELP

1

2817

Sat Jan 27, 2018 6:28 pm

carriedi View the latest

New Articles View the first 99 Buick Regal problems

in Buick

Cooter75

1

5589

Wed Oct 19, 2016 10:58 pm

carriedi View the latest

New Articles View the first 2002 Buick Park Ave

in Buick

asimmons3325

6

3080

Sat Jan 27, 2018 8:47 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us