2003 LeSabre Check Engine Code PO404

Buick Regal, Century and Park Avenue as well as the Rendezvous and Lesabre.
Ask our auto mechanics for help to all your Buick questions now.
Ray Price

2003 LeSabre Check Engine Code PO404

Unread post by Ray Price » Mon Oct 04, 2010 10:40 pm

Over the past year, the check engine light on my 2003 Buick LeSabre Custom has indicated a service engine soon PO404 code on three different occasions.

I have had my mechanic replace the EGR valve twice. Now, the check engine light is on again with the same code problem.

The acceleration is sluggish initially, but improves somewhat after the engine warms

Could this be something other than the EGR value?

BillBop

2003 LeSabre Check Engine Code PO404

Unread post by BillBop » Tue Oct 05, 2010 10:56 pm

If replacing the valve several times has not fixed it, then you have either a wiring problem, or a computer problem. You will need a schematic, volt / ohm meter and a scanner to diagnose this problem.

gwash
Posts: 1
Joined: Tue Dec 04, 2012 4:14 pm

2000 LeSabre Computer or sensor problem?

Unread post by gwash » Tue Dec 04, 2012 4:29 pm

I have been experiencing the following random failures:
o While driving, RPM guage drops to zero; engine continues to operate fine.
o While driving, RPM guage drops to zero simultaneous with a brief stutter or a hard shift; engine continues to operate fine.
o While driving, RPM guage drops to zero, volt indicator lights, engine dies. Sometimes I can shift into neutral, restart, and resume. Other times the engine may require several attempts to restart. Plenty of cranking power, but the engine sounds like it is not getting spark or fuel, until it restarts.
o While leaving a stop light, the engine falters and dies. It may or may not immediately restart.

These symptoms have happened relatively rarely, though the frequency has been increasing. I have never been stranded, as the restart occurs within 2-5 minutes. Sometimes (but not often) these symptoms cause the Service Engine Soon light to appear. The light disappears within 2 or 3 more times driving.

What do I need to do to diagnose the cause?

2000 LeSabre, approx 140,000 miles.

User avatar
ProTech
Posts: 652
Joined: Wed Oct 17, 2012 10:08 am

Re: 2000 LeSabre Computer or sensor problem?

Unread post by ProTech » Tue Dec 04, 2012 8:22 pm

This sounds like an ignition module that is going bad, which is pretty common on those engines. This would explain the RPM dropout, stalling, hesitation, etc.

Since you say the check engine light has come on before, I would highly recommend getting it scanned so you can see what codes are present. Even if the light is off now, there will be something stored from the previous time the light was on. This should help greatly in finding your problem, and most likely would end up being related to the ignition system or other ignition/fuel controlling sensor.

I've also seen crank sensors cause quite a bit of similar problems like you are experiencing, but usually they are heat affected and once they act up, say after driving a while, it will usually take a significant cool down period before the car will restart. You don't seem to be having that issue, but you never know.
GM Dealer Technician For 18+ Years
In the automotive industry for 20+

Post A Reply

  • Similar Topics
    Replies
    Views
    Last post