Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
I have an electrical problem on a 2004 Ford 250 4X4 with a 5.4 engine. The battery is not charging - replaced alternator and still not charging plus the gauges not working. I had it on a diagnostic machine and it said the PCM was bad. I replaced it and the problem is still there. Please can you help me... Thank you.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 

contributions: 11
did you check fusible links?

exactly what did diagnostic machine say?


   
Reply with quote  
 
User avatar

contributions: 2017
Images: 37
Location: Oregon
check the brown 18 gauge fusible link on the right side of the engine compartment. (or battery voltage on the orange and light blue wire at the alternator) Then check the yellow and white wire to the alternator. It should have battery power also, but it gets power before the brown fusible link. If they are ok and you have battery voltage there then check fuse #45 (10A) in the left side dash fuse panel.

if fuse #45 is blown check for damaged wires in the steering column for the over drive switch. the wires commonly get broken or worn where the shifter moves back and forth and will short our the fuse.

let me know what you find out please.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Attachment(s) Cruise control problem on a 2004 Ford Freestar

[ Go to page: 1, 2 ]

in Ford Cars

StephanieFran

8

3251

Mon Mar 28, 2016 2:09 pm

danbodart View the latest

New Articles View the first Ford f150 engine problem

[ Go to page: 1, 2 ]

in Ford Trucks

ohthomas69

9

2780

Sat Nov 22, 2014 5:44 pm

carriedi View the latest

New Articles View the first Ford Freestar headlights washers dim electrical

in Ford Trucks

onefeather

2

1256

Mon Feb 08, 2016 7:01 pm

onefeather View the latest

New Articles View the first 2004 Ford Expedition oil leak at radiator

in Ford Trucks

Droptine61

1

365

Sat Dec 31, 2016 10:11 pm

carriedi View the latest

New Articles View the first Ford 302 exhaust problem

in Ford Trucks

Topher

1

995

Sat Apr 09, 2016 12:21 pm

carriedi View the latest

New Articles View the first 1992 Ford F-150. XLT. 5.0 ignition module problem

in Ford Trucks

Car1966ter

3

1434

Tue Dec 16, 2014 12:07 pm

carriedi View the latest

New Articles View the first Ford Explorer Anti-theft problem

in Ford Trucks

Allen

1

1624

Fri Oct 02, 2015 3:01 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us