All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 4
2006 Ford F150 5.4
My parking brake light came on, and a few weeks later my ABS light came on. Now both lights are on, brakes seem to be working fine.
Brake fluid levels are fine.
Suggestions ?
Thanks,
Dynamitejake96


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2076
Images: 37
Location: Oregon
you should have the ABS scanned for codes to see what the computer is turning the light on for.

Maybe the fluid sensor isn't working correctly. If the master gets low and you refill it sometimes the float gets stuck at the bottom.

make sure the park brake switch is working correctly.


   
Reply with quote  
 

contributions: 4
Thanks,
I had it scanned yesterday.
They told me I need a new Electronic Control Unit [ 800.00 ]
Before they can even tell what is wrong with the ABS ?
Then they said they would be able to see what is causing the Parking Brake and The ABS light to be on ?
Sound Correct ???
Thanks....


   
Reply with quote  
 
User avatar

contributions: 2076
Images: 37
Location: Oregon
did they say they couldn't communicate with the ABS unit? is that why they say it needs to be replaced? If that is the case, did they verify the powers and grounds were all good before they condemned the unit?


   
Reply with quote  
 

contributions: 4
Yes, they said they could not communicate with ABS.
Yes, that is why they said I needed a new Electronic Control Unit.
Not sure, will check to make sure powers and grounds are all good.
Thanks for your INFO !!
dynamitejake96


   
Reply with quote  
 
User avatar

contributions: 2076
Images: 37
Location: Oregon
check the fuses in the central junction box by the right side A pillar.

fuse #2 20A light green wire to the brake switch then to pin #6 (hot all the time)
fuse 112 40A Yellow and light green wire wire to pin #13 (hot all the time)
fuse 103 20A orange and yellow wire to pin #14 (hot all the time)
fuse #14 10A light blue and pink wire to pin #8 (hot with key on)
fuse 15 5A red and yellow wire to the traction switch (hot with key on)

check for good grounds from pins #12 (black wire) and #15 (light green and yellow) at the abs module.

if all the fuses are good and there is power to those pins and the grounds are good grounds at the #12 and #15, then I would think that the abs module might be bad.


   
Reply with quote  
 

contributions: 4
Will check !
Thanks Again !!!
dynamitejake96


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2007 ford freestyle wrench light comes on and will not shift

in Ford Cars

DRDUFFY

2

1047

Fri Feb 10, 2017 8:39 pm

MaxTurn63 View the latest

New Articles View the first 1999 Ford Explorer Brake pedal down

in Ford Trucks

ajhank

3

1379

Thu Feb 25, 2016 11:42 am

carriedi View the latest

New Articles View the first theft light

in Ford Trucks

carproblems33

3

2222

Thu Aug 11, 2016 10:50 am

Guest View the latest

New Articles View the first ABS Light Only Appears Momentarily on Startup when Cold

in Ford Cars

searchlight

3

1588

Fri Oct 16, 2015 12:20 am

carriedi View the latest

New Articles View the first Dash warning light, tire pressurs

in Ford Trucks

signl22

3

1959

Tue Jun 02, 2015 6:34 pm

Jimmyb45 View the latest

New Articles View the first 93 f150 fuel problem need answers

in Ford Trucks

Drewh

1

617

Sun Jan 29, 2017 3:10 pm

carriedi View the latest

New Articles View the first 88 f150 electrical no dash or ignition power

in Ford Trucks

paulaka223

3

989

Sun Jul 10, 2016 2:32 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us