Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 3
The trailer and brake lights have stopped working. Fuses under dash check good. Under the hood are two boxes. One next to firewall has a large relay and two smaller ones. The other box has two of the large relays. The smaller ones click when the turn signals are on. Changed all relays in this box still nothing at plug. Vehicle is a 2004 f250 with a 5.4 motor. Need help


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 1992
Images: 37
Location: Oregon
the part that has three relays is for parking lamp, reverse lamps and the trailer battery charging.

the part that has two relays is for the left turn and right turn trailer lights. The fuse for the turn lights to the turn relays is fuse #6 (20A) and the parking or tail lights is the other fuse, #38 (20A). Fuse #6 goes out from the fuse as a dark green and orange wire. the fuse #38 goes directly to the relay. (no external wiring)

If the power from the fuse is good and you can hear the relay clicking, most likely there is a problem with the wiring going back to the trailer plugin. Have you check the trailer plugin to see if the trailer socket has power there or not?

wire from the turn relays is going to be dark green for right turn, and yellow for left turn. They should go all the way from the relay to the trailer socket. \

wire for the parking lights should be a brown and white wire from the relay to the trailer socket.

check for the correct power out and the wiring right by the relays and then check it back by the trailer socket.

Make sure you have a good ground at you trailer socket too. That affects all the trailer wiring.


   
Reply with quote  
 

contributions: 3
There is power to the running lights and electric brake at the pig tail on the rear. The part with three fuses is where I hear clicking when the turn d goals are on I also can feel it vibrate to. So to make sure I understand, the box with two relays are for the signals and brake lights.


   
Reply with quote  
 

contributions: 3
Found the trouble. It is in the connector to the pig tail at the rear. Shorting out. Thanks for the help


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Attachment(s) 1993 Mercury Cougar XR-7 Turn Signal & Brake Light Issues?

in Ford Cars

1964prostreetelcamino

1

1467

Tue Jul 15, 2014 6:07 pm

carriedi View the latest

New Articles View the first Expedition. Brake Fade. Not fixed with new Brake Master Cyl

in Ford Trucks

ExpeditionGuy

1

1623

Fri Aug 01, 2014 10:20 am

carriedi View the latest

New Articles View the first Speedometer not working on my 2000 Ford F250 super duty five

in Ford Trucks

Testercst

1

1425

Wed Sep 30, 2015 5:06 pm

carriedi View the latest

New Articles View the first brake problem with 85 Bronco

in Ford Trucks

Bushhog57

2

1556

Tue May 12, 2015 8:17 am

Bushhog57 View the latest

New Articles View the first Attachment(s) 99' Ford Explorer Sport turn signal multi switch

[ Go to page: 1, 2 ]

in Ford Trucks

MatthewinGA

9

499

Sat Jan 14, 2017 10:02 pm

MatthewinGA View the latest

New Articles View the first 96 ford mustang brake fluid in steering

in Ford Cars

pewkie1266

1

1578

Thu Jun 26, 2014 6:43 am

carriedi View the latest

New Articles View the first 1999 Ford Explorer Brake pedal down

in Ford Trucks

ajhank

3

1178

Thu Feb 25, 2016 11:42 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us