All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 3
I have an 02 silhouette. I have changed the fuel pump , filter anf relay and it still wont turn over. Yes its getting fuel we did the fuel pressure test. Can someone please help me.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2077
Images: 37
Location: Oregon
how much fuel pressure does it have? why did you do the fuel pump, filter and relay?

when you say it won't turn over do you mean the engine won't start or do you meay that the starter doesn't crank the engine over? Won't turn over means that the engine is not rotating when you turn the key to the start position. If that is the case you would need to look at the starter, starter relay, battery, neutral safety switch and the ignition switch. If you mean it turns over (rotates by means of the starter) but won't start, you have to verify your fuel pressure is up to spec, you have ignition spark and injector pulse when you are cranking.


   
Reply with quote  
 

contributions: 3
We changed the fuel filter cuz we thought it was clogged and it still didnt work so we tried the relay and then we changed the pump with a new one and it still wont stat like to put in drive. It cranks but it wont go. Im not sure how much the pressure was but I can see and how much should the pressure be?


   
Reply with quote  
 
User avatar

contributions: 2077
Images: 37
Location: Oregon
fuel pressure should be 52 to 59 psi.

ok, I am still a little confused. maybe it the terminology. when you turn the key to the start position, is the engine turning over? (starter engaging the engine and cranking the engine making it rotate, turn over) If the engine does turn over does it ever start up? Does is start up and then stall out or does it never start up, just cranks only?Understanding what is actually happening is key into figuring out what is going on


   
Reply with quote  
 

contributions: 3
I got it fixed it was the crank sensor. Thank you. It would turn over but never start. the starter was engaging but after some trial and error it was the crank sensor


   
Reply with quote  
 
User avatar

contributions: 2077
Images: 37
Location: Oregon
yep, no crank sensor signal and you get no spark and injector pulse to run. Congrats on getting it fixed


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first ICM burn up 99 Olds silhouette 3.4

in Oldsmobile

rschneider

1

551

Tue Dec 27, 2016 4:25 am

carriedi View the latest

New Articles View the first 2002 olds Silhouette

in Oldsmobile

Tbartif6

3

695

Wed Mar 22, 2017 12:19 am

carriedi View the latest

New Articles View the first Oldsmobile silhouette Ignition switch burned up

in Oldsmobile

janinep46

2

1145

Wed Jan 27, 2016 1:39 am

janinep46 View the latest

New Articles View the first Olds Silhouette Climate Control System

in Oldsmobile

Jeri

1

847

Sat Mar 12, 2016 1:57 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us