All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
My 06, impala 3.5 just died going down the road the key does nothing the dash lights don't come on can't roll up the window. And the scan tool I plug into the UBD2 linking error. Under the hood I found a blown ECM 10 amp fuse replaced it and still nothing. I'm thinking maybe my ECM needs replaced but of course I want to confirm before I spend the money with someone smarter than me. Thanks for what ever help you can give


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2093
Images: 37
Location: Oregon
doubling up on the posts? ecm/tcm 15 amp fuse powers up the engine and trans control modules. They make tools that you put in place of the blown fuse and can check the amp draw. you could measure the amps that are flowing through that circuit.

If the fuse doesn't blow, after replacing the fuse, check the powers and grounds for the ecm and tcm modules to see if they are both powering up or not


   
Reply with quote  
 

contributions: 2
I’m new to this and I can’t make a new topic.

I have. A 2010 impala l. 3.5 ls. What I have going on is when I first start the car I have no symptoms. The car drives perfect. About 10 to 15mins in when I approach a stop of any kind. I notice my speed o meter some what irractic. It goes up and down on its own and will shut off then and there with in 5 second tops. I also pu my digital speedometer display and it will say 112 mph( while I’m at a complete stop on drive). The trick I have working for me is coming to a stop I put the car on neutral, in which the car won’t shut off but still do the up and down on the speedometer needle. I have put a fuel cleaner no change.all my oils are at the correct levels. I also have NO CHECK ENGINE LIGHTS ON. Please if I can get advice on where to begin I would appreciate it. I’m a DIY SO I’m looking to solve this one. Not sure if it’s conecred but I also only have a/c blowing. I put the controls on hot by no hot air comes out at all not even while driving.


   
Reply with quote  
 
User avatar

contributions: 2093
Images: 37
Location: Oregon
you should use a scanner and see what the computer sees as speed. If the speedo and the computer don't match and the computer shows the correct speed then you may have a bad instrument cluster. The speedometer get it's information from the PCM. Scanning the pcm you should get the speed PID that is being sent to the dash. There may not be an engine code so no check engine light but scan for BCM or IPC codes


   
Reply with quote  
 

contributions: 2
I will try the odb reader. But I don’t think the speedometer being messed up would result in my car constantly shutting off at a stop. The car feels like it is choking before it shuts off. I have to rapidly place it on neutral so it won’t shut off.


   
Reply with quote  
 
User avatar

contributions: 2093
Images: 37
Location: Oregon
ok, so it's not that your speedometer shuts off, your engine shuts off at a stop. Or your engine stalls at stops.

a code reader and a scanner are not the same thing. A scanner will let you see the data stream. this way you can see what your computer is reacting to. what your fuel trims are. what your idle control is doing.See if your torque converter is releasing.

you said you notice it beginning to happen and you put the car in neutral to keep the engine running, what if you raise the engine rpm and use the brake? basically, power brake the engine at the stop? will it still die or can you keep it running?

Here's the thing, if the speedo goes erratic when coming to a stop and the engine stalls when coming to a stop, maybe it's connected. Maybe not, but you're going to have to try and figure out is it is related or if it's just a coincidence that they both happen at the same time.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 06 impala 3.5

in Chevy Cars

Jeremy

1

419

Sat Apr 29, 2017 12:54 am

carriedi View the latest

New Articles View the first 06 impala dont do nothing and the key won come off

in Chevy Cars

tururu

5

1969

Thu Aug 18, 2016 6:36 pm

carriedi View the latest

New Articles View the first Chevy Impala Won't Crank Over

in Chevy Cars

capricebb

1

674

Wed Mar 15, 2017 1:13 am

carriedi View the latest

New Articles View the first 2003 chevrolet impala

in Chevy Cars

pinetree

3

1889

Fri Apr 21, 2017 12:31 am

Guest View the latest

New Articles View the first 2003 Chevrolet Impala 3.4 liter

in Chevy Cars

Culpiesr2

1

436

Sat Sep 16, 2017 2:57 am

carriedi View the latest

New Articles View the first 2001 Impala grinding at specific RPM

in Chevy Cars

impala01

1

1448

Mon Dec 29, 2014 4:37 pm

carriedi View the latest

New Articles View the first 2005 Chevy Impala ignition

in Chevy Cars

gw5301989

1

167

Fri Nov 03, 2017 5:27 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us