Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
I HAVE A 2004 IMPALA 3.8L, 105K MI.COLD STARTS PERFECTLY NORMAL AFTER GETTING TO NORMAL OPERATING TEMP. ,AND CAR SHUT OFF FOR 30 MIN TO ABOUT 1 HR,CAR WILL START BUT STUMBLE AND SOMTIMES STALL BUT WILL ALWAYS RESTART, NO OTHER DRIVABILITY ISSUES CHANGED VERY DIRTY IAC.CLEANED MAF AND EGR OF COURSE NO CEL CHECKED FUEL PRESS,AND REGULATOR ALL NORMAL.LOCAL MECH SAYS POSSIBLE INTERMITTANT CRANK SENSOR BUT I'VE RED CAM SENSOR WILL CAUSE WARM START/STALL AND IS A LITTILE EASIER TO CHANGE ,IF CHANGED MUST A RELERN BE DONE AND HOW. THANKS FOR ALL HELP PETE


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 1988
Images: 37
Location: Oregon
you know, you might replace a lot of parts before you get it right. Before you throw a bunch of parts at it, (which is called the "shotgun" approach) yu should have the vehicle scanned. Scanning the data stream when the car acts up will be the easiest way to find out what the car is doing. It might be a fuel issue. It might be a TPS error. It might be either a crank or can issue. Recording the data stream will show you what the engine was responding to when the problem occurred. There are a lot of parts you could replace before you luck out and guess the right one. Or maybe not... you might replace a lot of parts and still not get it.

If you can't get a scanner that records the data stream see if you can find a shop that will do it for you. You will have to pay for their time and equipment but it may be cheaper that replacing parts that you didn't need.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2003 Chevy S-10 Stall out

in Chevy S-10 Pickup

Sling

1

302

Wed May 03, 2017 8:49 am

carriedi View the latest

New Articles View the first Cruise control not working 2004 Chevy Z71

in Chevy Suburban

drewstinson

1

584

Wed Nov 25, 2015 11:02 pm

carriedi View the latest

New Articles View the first Attachment(s) 2004 chevy silverado gauges not working

[ Go to page: 1, 2, 3 ]

in Chevy Silverado

Silverado2004

19

2690

Wed Aug 13, 2014 1:33 pm

Silverado2004 View the latest

New Articles View the first Blower motor 2004 Chevy impala wont shut off

in Chevy Cars

Konradtown

1

1090

Tue Apr 05, 2016 12:00 am

TerryAuto View the latest

New Articles View the first 98 Chevy 3/4 ton 4X4 hard to start

in Chevy Silverado

GrannyJo

1

675

Tue Jul 19, 2016 8:44 pm

carriedi View the latest

New Articles View the first 2005 Chevy Colorado bad start

in Chevy Trucks

Y2kvitual

3

804

Thu Sep 10, 2015 11:11 pm

carriedi View the latest

New Articles View the first Attachment(s) chevy cavalier wont start

in Chevy Cars

maine

3

1749

Tue Aug 26, 2014 10:29 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us