All times are UTC - 6 hours [ DST ]




Ask A Question Reply    Go to page 1, 2  Next
Author Message
 

contributions: 14
So this past weekend I pulled the oil pan from my 2007 chevy impala and changed the gas get due to it leaking! What a job that was. Got everything back together an in place no more leak also change a motor mount on the bottom of the motor took the vibration I was having away. Started the car drove fine next day the engine lite comes on and stays on had it scanned and it's putting off 5 different codes my problem is I'm loss with these coded don't think I have 5 different problems I'm guessing there all being put off for the same reason but who knows the codes are P0030,P0036,P0053,P0054,P0443. Any ideas an thoughts would be greatly appreciated as I can not afford to take it to a shop at this time! Thanks for taking the time to read!


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
well, the first four codes are for your oxygen sensor heaters. check to make sure don't have a wire pinched or the fuse may be blown. check 'Emission 1' fuse 15A in the underhood fuse panel. If that fuse is not completing the circuit it will turn on all those codes. That fuse powers up both Oxygen sensor heaters and also the evap purge solenoid

the last code is for evap purge solenoid circuit.

what is the 8th digit in your vehicles vin code? that will tell me what engine the car has.
3.5 vin K
3.5 vin N
3.9 vin R
5.3 vin C


   
Reply with quote  
 

contributions: 14
I have the 3.5 l in my impala I had already looked for any pinched wires none to be found knew nothing about the fuse! Checked the fuse an indeed it was bad would have never guessed a fuse could trigger the check engine lite to come on! I am greatly appreciative for your advise Carriedi thank you may God bless! Thank a whole lot save me at least 100$ to get it diagnosed!


   
Reply with quote  
 

contributions: 3
First time I've done this. It told me to post under someone else's topic.I recently purchased this car and I had this code come up. I had a lifter problem and the guy replaced 4. He puts the engine back to together and it still has that code. I have poor engine performance at times when accelerating. You notice it when you mash gas hard it bogs down or when car his 40mph it slows a bit. Starts and runs fine. Just issues list. Mechanic seems to believe it's the camshaft. Any ides or experience with this? Any help greatly appreciated.


   
Reply with quote  
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
what code do you have?


   
Reply with quote  
 

contributions: 3
I have the code p0016.


   
Reply with quote  
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
p0016 is the code for cam sensor to crank sensor correlation

clean good oil pressure is essential for the cam actuator to react normally. Sludge build up can affect the operation of the cam actuator.

Using a scanner, look at the cam and a crank sensor data.

how does the engine run? does it run smoothly? No shaking, no misfires, etc.?


   
Reply with quote  
 

contributions: 3
It was running it's best before I put 4 lifters into it. They were all pretty ruff and worn dow. The mechanic said he didn't check the other ones and that he probably should have. Now it has a pretty bad skip or misfire but there is no misfire detected in the computer scanner. IT'S drivable but sounds horrible and burns quite a bit of gas. Engine oil is clean. Changed recently.


   
Reply with quote  
Ask A Question Reply    Go to page 1, 2  Next

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2005 engine check light flashing when accelerated

in Chevy Cars

Demyann

3

1069

Thu Sep 15, 2016 10:54 am

carriedi View the latest

New Articles View the first 2001 chevy impala

in Chevy Cars

daisha

1

1826

Sat Nov 08, 2014 6:33 pm

carriedi View the latest

New Articles View the first Chevy Impala Won't Crank Over

in Chevy Cars

capricebb

1

600

Wed Mar 15, 2017 1:13 am

carriedi View the latest

New Articles View the first 2003 Chevy Impala accelerating slow

in Chevy Cars

belcollege

1

1679

Wed Jan 28, 2015 3:20 am

carriedi View the latest

New Articles View the first 2002 Chevy Impala-Instrument Panel Lights

in Chevy Cars

Rinda

7

2340

Thu Jan 01, 2015 5:53 pm

carriedi View the latest

New Articles View the first Blower motor 2004 Chevy impala wont shut off

in Chevy Cars

Konradtown

1

1266

Tue Apr 05, 2016 12:00 am

TerryAuto View the latest

New Articles View the first 2000 suburban back ac not working

in Chevy Suburban

Angelicwhisp

1

417

Tue Feb 21, 2017 11:50 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us