GreatAutoHelp.com Car Forums
http://www.greatautohelp.com/forums/

2000 chevy impala cuts off
http://www.greatautohelp.com/forums/viewtopic.php?f=3&t=6017
Page 1 of 2

Author:  kandysav [ Mon Sep 09, 2013 9:26 pm ]
2000 chevy impala cuts off

I let my car sit and warm up every morning before I pull off but sometimes it acts like it wants to cut off while im pressing the gas...One day I was driving down highway and the car just cut off..it started back up and has only done it once again but this time I had to mash on the gas while starting it....any suggestions on what maybe wrong?

Author:  carriedi [ Wed Sep 11, 2013 10:39 am ]
Re: 2000 chevy impala cuts off

sorry but there is not enough information to lead to a diagnosis. Ignition switch, crank sensor, fuel pump, MAP or MAF sensor, PCM, fuel pressure regulator, battery connection...

you may want to have your car scanned to see if memory or secondary code may have been set.

Author:  RadarBlitz [ Sat Jun 20, 2015 3:04 pm ]
Re: 2000 chevy impala cuts off

Hi,
I have a 2000 3.8 Chevy Impala. When the car gets to temp, around 210 degrees, the engine will shut off. When it gets around 180 degrees it will start. It will crank but not fire. When it won't start there there isn't spark from the coils and no fuel injector pulses. I checked the fuel pressure and it remains around 48psi. I've replaced the crank sensor, ICM, cam sensor, wire harness to the ICM and sensors, map sensor, maf sensor and temp sensor. I've disconnected all of the fuel injector connectors to see if it was a shorted fuel injector. I disconnected the coils one at a time to see if a coil was the cause, no help. I also unplugged the connectors from the BCM, and ECM and cleaned, still no help. I cleaned the ground and even ran a separate ground wire to the ICM. I've used freeze spay on all of the above components and even wiggled the wire harness around. No codes are given either. I even installed a passlock bypass. Any ideas?

Author:  carriedi [ Sun Jun 21, 2015 7:57 pm ]
Re: 2000 chevy impala cuts off

ok, because you have no spark, that's what you have to run down first.

what engine do you have?

Author:  RadarBlitz [ Mon Jun 22, 2015 10:55 am ]
Re: 2000 chevy impala cuts off

It's a 3.8 retired police car with 130,000 miles

Author:  carriedi [ Mon Jun 22, 2015 10:48 pm ]
Re: 2000 chevy impala cuts off

ok, you need to test for your signal coming into your ignition control module from the crank sensor. Measure at the Ignition control module wire harness connector not at the crank sensor connector. You want to make sure the crank signal is getting back to the ICM

Here's a page that tells you how to check the sensor

http://troubleshootmyvehicle.com/gm/3.8 ... k-sensor-1

Author:  RadarBlitz [ Tue Jun 23, 2015 10:00 pm ]
Re: 2000 chevy impala cuts off

I've originally went this path from the start, and changed the crank sensor 1st. Then the complete wire harness to it and the ICM. I will recheck for signal pulses and get back to you as soon as I can.

Author:  RadarBlitz [ Sat Aug 15, 2015 3:46 pm ]
Re: 2000 chevy impala cuts off

Sorry for the long delay. The Crank sensor was the culprit, this was frustrating because it was the first part that I replaced about 6 months prior. The sensor would put out a signal, but the amplitude was weaker. I hope the new sensor lasts longer. I did make a test hook up from the old harness and remaining parts to do some easier testing next time.

Page 1 of 2 All times are UTC - 6 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/